diff mbox series

[4/9] package/libselinux: enable kernel selinux support for ext3 images

Message ID 20200731204100.1171427-5-aduskett@gmail.com
State Accepted, archived
Headers show
Series package/libselinux: kernel munging fixups | expand

Commit Message

Adam Duskett July 31, 2020, 8:40 p.m. UTC
From: Adam Duskett <Aduskett@gmail.com>

If BR2_TARGET_ROOTFS_EXT2_3 is selected, enable the following kernel options:
  - CONFIG_EXT3_FS_SECURITY

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
---
 package/libselinux/libselinux.mk | 2 ++
 1 file changed, 2 insertions(+)
diff mbox series

Patch

diff --git a/package/libselinux/libselinux.mk b/package/libselinux/libselinux.mk
index 77efe2d8e0..525f4fe9a2 100644
--- a/package/libselinux/libselinux.mk
+++ b/package/libselinux/libselinux.mk
@@ -118,6 +118,8 @@  define LIBSELINUX_LINUX_CONFIG_FIXUPS
 	$(if $(BR2_TARGET_ROOTFS_EXT2),
 		$(call KCONFIG_ENABLE_OPT,CONFIG_EXT2_FS_XATTR)
 		$(call KCONFIG_ENABLE_OPT,CONFIG_EXT2_FS_SECURITY))
+	$(if $(BR2_TARGET_ROOTFS_EXT2_3),
+		$(call KCONFIG_ENABLE_OPT,CONFIG_EXT3_FS_SECURITY))
 endef
 
 $(eval $(generic-package))