diff mbox series

[2/9] package/libselinux: enable kernel selinux support for erofs images

Message ID 20200731204100.1171427-3-aduskett@gmail.com
State Accepted, archived
Headers show
Series package/libselinux: kernel munging fixups | expand

Commit Message

Adam Duskett July 31, 2020, 8:40 p.m. UTC
From: Adam Duskett <Aduskett@gmail.com>

If BR2_TARGET_ROOTFS_EROFS is selected, enable the following kernel options:
  - CONFIG_EROFS_FS_XATTR
  - CONFIG_EROFS_FS_SECURITY

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
---
 package/libselinux/libselinux.mk | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/package/libselinux/libselinux.mk b/package/libselinux/libselinux.mk
index 521dbaaba8..b8f9c3b55a 100644
--- a/package/libselinux/libselinux.mk
+++ b/package/libselinux/libselinux.mk
@@ -112,6 +112,9 @@  define LIBSELINUX_LINUX_CONFIG_FIXUPS
 	$(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY_NETWORK)
 	$(call KCONFIG_ENABLE_OPT,CONFIG_SECURITY_SELINUX)
 	$(call KCONFIG_SET_OPT,CONFIG_LSM,"selinux")
+	$(if $(BR2_TARGET_ROOTFS_EROFS),
+		$(call KCONFIG_ENABLE_OPT,CONFIG_EROFS_FS_XATTR)
+		$(call KCONFIG_ENABLE_OPT,CONFIG_EROFS_FS_SECURITY))
 endef
 
 $(eval $(generic-package))