diff mbox series

[v2,03/10] package/lua-compat53: unsupport of Lua 5.4, as 5.3

Message ID 20200728125613.3153975-4-francois.perrad@gadz.org
State Superseded
Headers show
Series Lua 5.4 | expand

Commit Message

Francois Perrad July 28, 2020, 12:56 p.m. UTC
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 package/lua-compat53/Config.in | 2 +-
 package/lua-http/Config.in     | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
diff mbox series

Patch

diff --git a/package/lua-compat53/Config.in b/package/lua-compat53/Config.in
index 76c5b3fd7..38a6b12f8 100644
--- a/package/lua-compat53/Config.in
+++ b/package/lua-compat53/Config.in
@@ -1,6 +1,6 @@ 
 config BR2_PACKAGE_LUA_COMPAT53
 	bool "lua-compat53"
-	depends on !BR2_PACKAGE_LUA_5_3
+	depends on !BR2_PACKAGE_LUA_5_3 && !BR2_PACKAGE_LUA_5_4
 	help
 	  Compatibility module providing Lua-5.3-style APIs for Lua 5.2
 	  and 5.1.
diff --git a/package/lua-http/Config.in b/package/lua-http/Config.in
index cbf71563b..19a77f107 100644
--- a/package/lua-http/Config.in
+++ b/package/lua-http/Config.in
@@ -4,7 +4,7 @@  config BR2_PACKAGE_LUA_HTTP
 	select BR2_PACKAGE_LPEG # runtime
 	select BR2_PACKAGE_LUA_BASEXX # runtime
 	select BR2_PACKAGE_LUA_BINARYHEAP # runtime
-	select BR2_PACKAGE_LUA_COMPAT53 if !BR2_PACKAGE_LUA_5_3 # runtime
+	select BR2_PACKAGE_LUA_COMPAT53 if !BR2_PACKAGE_LUA_5_3 && !BR2_PACKAGE_LUA_5_4 # runtime
 	select BR2_PACKAGE_LUA_CQUEUES # runtime
 	select BR2_PACKAGE_LUA_FIFO # runtime
 	select BR2_PACKAGE_LUA_LPEG_PATTERNS # runtime