diff mbox series

[1/2] package/squid: add optional systemd dependency

Message ID 20200723215623.890307-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/2] package/squid: add optional systemd dependency | expand

Commit Message

Fabrice Fontaine July 23, 2020, 9:56 p.m. UTC
systemd is an optional dependency (enabled by default) since version
4.11 and
https://github.com/squid-cache/squid/commit/6fa8c66435d55a2e713db0222cdca3a9dccf5bbe

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/squid/squid.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Peter Korsgaard July 25, 2020, 6:04 a.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > systemd is an optional dependency (enabled by default) since version
 > 4.11 and
 > https://github.com/squid-cache/squid/commit/6fa8c66435d55a2e713db0222cdca3a9dccf5bbe

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
Peter Korsgaard July 25, 2020, 7:29 a.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > systemd is an optional dependency (enabled by default) since version
 > 4.11 and
 > https://github.com/squid-cache/squid/commit/6fa8c66435d55a2e713db0222cdca3a9dccf5bbe

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2020.02.x and 2020.05.x, thanks.
diff mbox series

Patch

diff --git a/package/squid/squid.mk b/package/squid/squid.mk
index d281eee3ed..ef2f84085c 100644
--- a/package/squid/squid.mk
+++ b/package/squid/squid.mk
@@ -62,6 +62,13 @@  else
 SQUID_CONF_OPTS += --without-gnutls
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD),y)
+SQUID_CONF_OPTS += --with-systemd
+SQUID_DEPENDENCIES += systemd
+else
+SQUID_CONF_OPTS += --without-systemd
+endif
+
 define SQUID_CLEANUP_TARGET
 	rm -f $(addprefix $(TARGET_DIR)/usr/bin/, \
 		RunCache RunAccel)