diff mbox series

package/bitwise: add package

Message ID 20200706041904.1518500-1-rfried.dev@gmail.com
State Changes Requested
Headers show
Series package/bitwise: add package | expand

Commit Message

Ramon Fried July 6, 2020, 4:19 a.m. UTC
Bitwise is multi base interactive calculator supporting dynamic
base conversion and bit manipulation.
It's a handy tool for low level hackers,
kernel developers and device drivers developers.

Signed-off-by: Ramon Fried <rfried.dev@gmail.com>
---
 package/Config.in            |  1 +
 package/bitwise/Config.in    | 10 ++++++++++
 package/bitwise/bitwise.hash |  1 +
 package/bitwise/bitwise.mk   | 12 ++++++++++++
 4 files changed, 24 insertions(+)
 create mode 100644 package/bitwise/Config.in
 create mode 100644 package/bitwise/bitwise.hash
 create mode 100644 package/bitwise/bitwise.mk

Comments

Thomas Petazzoni July 6, 2020, 7:36 a.m. UTC | #1
Hello,

Thanks for your contribution! The commit title should be
"package/bitwise: new package".

On Mon,  6 Jul 2020 07:19:04 +0300
Ramon Fried <rfried.dev@gmail.com> wrote:

> Bitwise is multi base interactive calculator supporting dynamic
> base conversion and bit manipulation.
> It's a handy tool for low level hackers,
> kernel developers and device drivers developers.
> 
> Signed-off-by: Ramon Fried <rfried.dev@gmail.com>
> ---
>  package/Config.in            |  1 +
>  package/bitwise/Config.in    | 10 ++++++++++
>  package/bitwise/bitwise.hash |  1 +
>  package/bitwise/bitwise.mk   | 12 ++++++++++++
>  4 files changed, 24 insertions(+)

You need to update the DEVELOPERS file.


> diff --git a/package/bitwise/Config.in b/package/bitwise/Config.in
> new file mode 100644
> index 0000000000..07e6580d14
> --- /dev/null
> +++ b/package/bitwise/Config.in
> @@ -0,0 +1,10 @@
> +config BR2_PACKAGE_BITWISE
> +	bool "bitwise"
> +	select BR2_PACKAGE_NCURSES
> +	select BR2_PACKAGE_READLINE
> +	help
> +	  Bitwise is multi base interactive calculator supporting dynamic base
> +	  conversion and bit manipulation. It's a handy tool for low level hackers,
> +	  kernel developers and device drivers developers.

I think some of those lines are too long. Could you run "make
check-package" ?

> diff --git a/package/bitwise/bitwise.hash b/package/bitwise/bitwise.hash
> new file mode 100644
> index 0000000000..35a1109b93
> --- /dev/null
> +++ b/package/bitwise/bitwise.hash
> @@ -0,0 +1 @@
> +sha256 33ce934fb99dadf7652224152cc135a0abf6a211adde53d96e9be7067567749c  bitwise-v0.41.tar.gz
> diff --git a/package/bitwise/bitwise.mk b/package/bitwise/bitwise.mk
> new file mode 100644
> index 0000000000..2bc21da4b2
> --- /dev/null
> +++ b/package/bitwise/bitwise.mk
> @@ -0,0 +1,12 @@
> +#
> +# bitwise
> +#
> +################################################################################

The comment header is not complete, the first line full of #### is
missing.

> +BITWISE_VERSION = v0.41

This should be just 0.41

> +BITWISE_SITE = https://github.com/mellowcandle/bitwise/releases/download/$(BITWISE_VERSION)
> +BITWISE_SOURCE = bitwise-$(BITWISE_VERSION).tar.gz

So this should be:

BITWISE_SOURCE = bitwise-v$(BITWISE_VERSION).tar.gz

> +BITWISE_DEPENDENCIES= ncurses readline

Space before =. This is reported by "make check-package" as well I
believe.

> +BITWISE_LICENSE = GPL-2.0
> +BITWISE_LICENSE_FILES = COPYING

We need an empty line before the eval autotools-package line.

> +$(eval $(autotools-package))

Thanks!

Thomas
Ramon Fried July 6, 2020, 8:24 a.m. UTC | #2
On Mon, Jul 6, 2020 at 10:36 AM Thomas Petazzoni
<thomas.petazzoni@bootlin.com> wrote:
>
> Hello,
>
> Thanks for your contribution! The commit title should be
> "package/bitwise: new package".
Thanks, Fixed everything. sending v2.
diff mbox series

Patch

diff --git a/package/Config.in b/package/Config.in
index 6a34a895af..f159d4ee5c 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -147,6 +147,7 @@  endmenu
 
 menu "Development tools"
 	source "package/bats-core/Config.in"
+	source "package/bitwise/Config.in"
 	source "package/binutils/Config.in"
 	source "package/bsdiff/Config.in"
 	source "package/bustle/Config.in"
diff --git a/package/bitwise/Config.in b/package/bitwise/Config.in
new file mode 100644
index 0000000000..07e6580d14
--- /dev/null
+++ b/package/bitwise/Config.in
@@ -0,0 +1,10 @@ 
+config BR2_PACKAGE_BITWISE
+	bool "bitwise"
+	select BR2_PACKAGE_NCURSES
+	select BR2_PACKAGE_READLINE
+	help
+	  Bitwise is multi base interactive calculator supporting dynamic base
+	  conversion and bit manipulation. It's a handy tool for low level hackers,
+	  kernel developers and device drivers developers.
+
+	  https://github.com/mellowcandle/bitwise
diff --git a/package/bitwise/bitwise.hash b/package/bitwise/bitwise.hash
new file mode 100644
index 0000000000..35a1109b93
--- /dev/null
+++ b/package/bitwise/bitwise.hash
@@ -0,0 +1 @@ 
+sha256 33ce934fb99dadf7652224152cc135a0abf6a211adde53d96e9be7067567749c  bitwise-v0.41.tar.gz
diff --git a/package/bitwise/bitwise.mk b/package/bitwise/bitwise.mk
new file mode 100644
index 0000000000..2bc21da4b2
--- /dev/null
+++ b/package/bitwise/bitwise.mk
@@ -0,0 +1,12 @@ 
+#
+# bitwise
+#
+################################################################################
+
+BITWISE_VERSION = v0.41
+BITWISE_SITE = https://github.com/mellowcandle/bitwise/releases/download/$(BITWISE_VERSION)
+BITWISE_SOURCE = bitwise-$(BITWISE_VERSION).tar.gz
+BITWISE_DEPENDENCIES= ncurses readline
+BITWISE_LICENSE = GPL-2.0
+BITWISE_LICENSE_FILES = COPYING
+$(eval $(autotools-package))