diff mbox series

fs/ubi: expose BINARIES_DIR to ubinize.cfg

Message ID 20200606105015.1603519-1-alexandre.belloni@bootlin.com
State Accepted
Headers show
Series fs/ubi: expose BINARIES_DIR to ubinize.cfg | expand

Commit Message

Alexandre Belloni June 6, 2020, 10:50 a.m. UTC
It is often necessary to refer to other images that are present in
BINARIES_DIR from a custom ubinize configuration e.g. to include the kernel
in a UBI volume.

As for BR2_ROOTFS_UBIFS_PATH, replace BINARIES_DIR when copying the file.

Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
---
 fs/ubi/ubi.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Yann E. MORIN June 6, 2020, 11:46 a.m. UTC | #1
Alexandre, All,

On 2020-06-06 12:50 +0200, Alexandre Belloni spake thusly:
> It is often necessary to refer to other images that are present in
> BINARIES_DIR from a custom ubinize configuration e.g. to include the kernel
> in a UBI volume.
> 
> As for BR2_ROOTFS_UBIFS_PATH, replace BINARIES_DIR when copying the file.
> 
> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>

You forgot to update the help text to also mention this replacement, so
I did add a blurb there, and applied to master (with a rewrpaeed commit
log, too). Thanks.

Regards,
Yann E. MORIN.

> ---
>  fs/ubi/ubi.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/fs/ubi/ubi.mk b/fs/ubi/ubi.mk
> index d848f8b23a65..54bb81ea08a4 100644
> --- a/fs/ubi/ubi.mk
> +++ b/fs/ubi/ubi.mk
> @@ -23,7 +23,7 @@ endif
>  # don't use sed -i as it misbehaves on systems with SELinux enabled when this is
>  # executed through fakeroot (see #9386)
>  define ROOTFS_UBI_CMD
> -	sed 's;BR2_ROOTFS_UBIFS_PATH;$@fs;' \
> +	sed 's;BR2_ROOTFS_UBIFS_PATH;$@fs;;s;BINARIES_DIR;$(BINARIES_DIR);' \
>  		$(UBI_UBINIZE_CONFIG_FILE_PATH) > $(BUILD_DIR)/ubinize.cfg
>  	$(HOST_DIR)/sbin/ubinize -o $@ $(UBI_UBINIZE_OPTS) $(BUILD_DIR)/ubinize.cfg
>  	rm $(BUILD_DIR)/ubinize.cfg
> -- 
> 2.26.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard July 5, 2020, 8:59 p.m. UTC | #2
>>>>> "Alexandre" == Alexandre Belloni <alexandre.belloni@bootlin.com> writes:

 > It is often necessary to refer to other images that are present in
 > BINARIES_DIR from a custom ubinize configuration e.g. to include the kernel
 > in a UBI volume.

 > As for BR2_ROOTFS_UBIFS_PATH, replace BINARIES_DIR when copying the file.

 > Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>

While not strictly a bugfix, it seems pretty simple and a sensible thing
to do, so committed to 2020.02.x, thanks.
diff mbox series

Patch

diff --git a/fs/ubi/ubi.mk b/fs/ubi/ubi.mk
index d848f8b23a65..54bb81ea08a4 100644
--- a/fs/ubi/ubi.mk
+++ b/fs/ubi/ubi.mk
@@ -23,7 +23,7 @@  endif
 # don't use sed -i as it misbehaves on systems with SELinux enabled when this is
 # executed through fakeroot (see #9386)
 define ROOTFS_UBI_CMD
-	sed 's;BR2_ROOTFS_UBIFS_PATH;$@fs;' \
+	sed 's;BR2_ROOTFS_UBIFS_PATH;$@fs;;s;BINARIES_DIR;$(BINARIES_DIR);' \
 		$(UBI_UBINIZE_CONFIG_FILE_PATH) > $(BUILD_DIR)/ubinize.cfg
 	$(HOST_DIR)/sbin/ubinize -o $@ $(UBI_UBINIZE_OPTS) $(BUILD_DIR)/ubinize.cfg
 	rm $(BUILD_DIR)/ubinize.cfg