diff mbox series

package/libxml2: remove helper script from target

Message ID 20200605225719.13836-1-nolange79@gmail.com
State Accepted
Headers show
Series package/libxml2: remove helper script from target | expand

Commit Message

Norbert Lange June 5, 2020, 10:57 p.m. UTC
Signed-off-by: Norbert Lange <nolange79@gmail.com>
---
 package/libxml2/libxml2.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Thomas Petazzoni June 6, 2020, 8:15 p.m. UTC | #1
On Sat,  6 Jun 2020 00:57:18 +0200
Norbert Lange <nolange79@gmail.com> wrote:

> Signed-off-by: Norbert Lange <nolange79@gmail.com>
> ---
>  package/libxml2/libxml2.mk | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/package/libxml2/libxml2.mk b/package/libxml2/libxml2.mk
> index ea6a8c1f6d..a0efe041a5 100644
> --- a/package/libxml2/libxml2.mk
> +++ b/package/libxml2/libxml2.mk
> @@ -49,6 +49,12 @@ else
>  LIBXML2_CONF_OPTS += --without-iconv
>  endif
>  
> +define LIBXML2_INSTALL_TARGET_POST

LIBXML2_INSTALL_TARGET_POST is really not a great name: we want a name
that is more descriptive of what the hook is doing. So I renamed to
LIBXML2_CLEANUP_XML2CONF, and applied to master. Thanks!

Thomas
Peter Korsgaard July 6, 2020, 7:16 a.m. UTC | #2
>>>>> "Norbert" == Norbert Lange <nolange79@gmail.com> writes:

 > Signed-off-by: Norbert Lange <nolange79@gmail.com>

Committed to 2020.02.x and 2020.05.x, thanks.
diff mbox series

Patch

diff --git a/package/libxml2/libxml2.mk b/package/libxml2/libxml2.mk
index ea6a8c1f6d..a0efe041a5 100644
--- a/package/libxml2/libxml2.mk
+++ b/package/libxml2/libxml2.mk
@@ -49,6 +49,12 @@  else
 LIBXML2_CONF_OPTS += --without-iconv
 endif
 
+define LIBXML2_INSTALL_TARGET_POST
+	rm -f $(TARGET_DIR)/usr/lib/xml2Conf.sh
+endef
+
+LIBXML2_POST_INSTALL_TARGET_HOOKS += LIBXML2_INSTALL_TARGET_POST
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))