diff mbox series

[1/2] package/libhttpserver: disable examples

Message ID 20200604213522.12291-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/2] package/libhttpserver: disable examples | expand

Commit Message

Fabrice Fontaine June 4, 2020, 9:35 p.m. UTC
examples are enabled by default since version 0.17.5 and
https://github.com/etr/libhttpserver/commit/012d014a7c52ef91a35c521d5d4f83ee11de5068

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libhttpserver/libhttpserver.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Stephan Hoffmann June 5, 2020, 7:13 a.m. UTC | #1
Am 04.06.20 um 23:35 schrieb Fabrice Fontaine:
> examples are enabled by default since version 0.17.5 and
> https://github.com/etr/libhttpserver/commit/012d014a7c52ef91a35c521d5d4f83ee11de5068
>
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Stephan Hoffmann <sho@relinux.de>
> ---
>  package/libhttpserver/libhttpserver.mk | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/package/libhttpserver/libhttpserver.mk b/package/libhttpserver/libhttpserver.mk
> index 1fd76519f4..2c536cf012 100644
> --- a/package/libhttpserver/libhttpserver.mk
> +++ b/package/libhttpserver/libhttpserver.mk
> @@ -9,7 +9,9 @@ LIBHTTPSERVER_SITE = $(call github,etr,libhttpserver,$(LIBHTTPSERVER_VERSION))
>  LIBHTTPSERVER_LICENSE = LGPL-2.1+
>  LIBHTTPSERVER_LICENSE_FILES = COPYING.LESSER
>  LIBHTTPSERVER_INSTALL_STAGING = YES
> -LIBHTTPSERVER_CONF_OPTS = --enable-same-directory-build
> +LIBHTTPSERVER_CONF_OPTS = \
> +	--disable-examples \
> +	--enable-same-directory-build
>  LIBHTTPSERVER_AUTORECONF = YES
>  LIBHTTPSERVER_DEPENDENCIES = libmicrohttpd
>
Yann E. MORIN June 6, 2020, 9:35 a.m. UTC | #2
Fabrice, All,

On 2020-06-04 23:35 +0200, Fabrice Fontaine spake thusly:
> examples are enabled by default since version 0.17.5 and
> https://github.com/etr/libhttpserver/commit/012d014a7c52ef91a35c521d5d4f83ee11de5068
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Both applied to master, thanks.

> ---
>  package/libhttpserver/libhttpserver.mk | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
> 
> diff --git a/package/libhttpserver/libhttpserver.mk b/package/libhttpserver/libhttpserver.mk
> index 1fd76519f4..2c536cf012 100644
> --- a/package/libhttpserver/libhttpserver.mk
> +++ b/package/libhttpserver/libhttpserver.mk
> @@ -9,7 +9,9 @@ LIBHTTPSERVER_SITE = $(call github,etr,libhttpserver,$(LIBHTTPSERVER_VERSION))
>  LIBHTTPSERVER_LICENSE = LGPL-2.1+
>  LIBHTTPSERVER_LICENSE_FILES = COPYING.LESSER
>  LIBHTTPSERVER_INSTALL_STAGING = YES
> -LIBHTTPSERVER_CONF_OPTS = --enable-same-directory-build
> +LIBHTTPSERVER_CONF_OPTS = \
> +	--disable-examples \
> +	--enable-same-directory-build
>  LIBHTTPSERVER_AUTORECONF = YES
>  LIBHTTPSERVER_DEPENDENCIES = libmicrohttpd
>  
> -- 
> 2.26.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Peter Korsgaard June 21, 2020, 9:28 p.m. UTC | #3
>>>>> "Stephan" == Stephan Hoffmann <sho@relinux.de> writes:

 > Am 04.06.20 um 23:35 schrieb Fabrice Fontaine:
 >> examples are enabled by default since version 0.17.5 and
 >> https://github.com/etr/libhttpserver/commit/012d014a7c52ef91a35c521d5d4f83ee11de5068

Committed to 2020.02.x and 2020.05.x, thanks.
diff mbox series

Patch

diff --git a/package/libhttpserver/libhttpserver.mk b/package/libhttpserver/libhttpserver.mk
index 1fd76519f4..2c536cf012 100644
--- a/package/libhttpserver/libhttpserver.mk
+++ b/package/libhttpserver/libhttpserver.mk
@@ -9,7 +9,9 @@  LIBHTTPSERVER_SITE = $(call github,etr,libhttpserver,$(LIBHTTPSERVER_VERSION))
 LIBHTTPSERVER_LICENSE = LGPL-2.1+
 LIBHTTPSERVER_LICENSE_FILES = COPYING.LESSER
 LIBHTTPSERVER_INSTALL_STAGING = YES
-LIBHTTPSERVER_CONF_OPTS = --enable-same-directory-build
+LIBHTTPSERVER_CONF_OPTS = \
+	--disable-examples \
+	--enable-same-directory-build
 LIBHTTPSERVER_AUTORECONF = YES
 LIBHTTPSERVER_DEPENDENCIES = libmicrohttpd