diff mbox series

[v2,3/4] package/redis: add optional support for TLS connections

Message ID 20200602104011.837-4-titouan.christophe@railnova.eu
State Accepted
Headers show
Series package/redis: bump to Redis 6 | expand

Commit Message

Titouan Christophe June 2, 2020, 10:40 a.m. UTC
Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
---
 package/redis/redis.mk | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Yann E. MORIN June 5, 2020, 10:32 p.m. UTC | #1
Titouan, All,

On 2020-06-02 12:40 +0200, Titouan Christophe spake thusly:
> Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
> ---
>  package/redis/redis.mk | 5 +++++
>  1 file changed, 5 insertions(+)
> 
> diff --git a/package/redis/redis.mk b/package/redis/redis.mk
> index 1578f97e0d..c88e107c2b 100644
> --- a/package/redis/redis.mk
> +++ b/package/redis/redis.mk
> @@ -30,6 +30,11 @@ endif
>  REDIS_BUILDOPTS = $(TARGET_CONFIGURE_OPTS) \
>  	PREFIX=$(TARGET_DIR)/usr MALLOC=libc
>  
> +ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
> +REDIS_DEPENDENCIES += libopenssl
> +REDIS_BUILDOPTS += BUILD_TLS=yes

I've added the =no case otherwise, for consistency with other parts of
the code (--enabel/--disable for autotools packages), and to avoid an
environemnt variable from leaking.

Applied to master with that fixed, thanks.

Regards,
Yann E. MORIN.

> +endif
> +
>  define REDIS_BUILD_CMDS
>  	$(TARGET_MAKE_ENV) $(MAKE) $(REDIS_BUILDOPTS) -C $(@D)
>  endef
> -- 
> 2.25.3
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/redis/redis.mk b/package/redis/redis.mk
index 1578f97e0d..c88e107c2b 100644
--- a/package/redis/redis.mk
+++ b/package/redis/redis.mk
@@ -30,6 +30,11 @@  endif
 REDIS_BUILDOPTS = $(TARGET_CONFIGURE_OPTS) \
 	PREFIX=$(TARGET_DIR)/usr MALLOC=libc
 
+ifeq ($(BR2_PACKAGE_LIBOPENSSL),y)
+REDIS_DEPENDENCIES += libopenssl
+REDIS_BUILDOPTS += BUILD_TLS=yes
+endif
+
 define REDIS_BUILD_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) $(REDIS_BUILDOPTS) -C $(@D)
 endef