diff mbox series

[v1] package/cvs: fix mktime related compile failure

Message ID 20200528203204.18142-1-ps.report@gmx.net
State Changes Requested
Headers show
Series [v1] package/cvs: fix mktime related compile failure | expand

Commit Message

Peter Seiderer May 28, 2020, 8:32 p.m. UTC
Use ac_cv_func_working_mktime=yes to force the use of a provided
mktime implementation instead of compiling the failing own one.

Fixes:

  http://autobuild.buildroot.net/results/5bcd8f4235002da682cc900f866116d2fe87f1c8

  mktime.c: In function 'ydhms_diff':
  mktime.c:106:52: error: size of array 'a' is negative
   #define verify(name, assertion) struct name { char a[(assertion) ? 1 : -1]; }
                                                      ^
  mktime.c:170:3: note: in expansion of macro 'verify'
     verify (long_int_year_and_yday_are_wide_enough,
     ^~~~~~

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
 package/cvs/cvs.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni May 28, 2020, 8:43 p.m. UTC | #1
On Thu, 28 May 2020 22:32:04 +0200
Peter Seiderer <ps.report@gmx.net> wrote:

> Use ac_cv_func_working_mktime=yes to force the use of a provided
> mktime implementation instead of compiling the failing own one.
> 
> Fixes:
> 
>   http://autobuild.buildroot.net/results/5bcd8f4235002da682cc900f866116d2fe87f1c8
> 
>   mktime.c: In function 'ydhms_diff':
>   mktime.c:106:52: error: size of array 'a' is negative
>    #define verify(name, assertion) struct name { char a[(assertion) ? 1 : -1]; }
>                                                       ^
>   mktime.c:170:3: note: in expansion of macro 'verify'
>      verify (long_int_year_and_yday_are_wide_enough,
>      ^~~~~~
> 
> Signed-off-by: Peter Seiderer <ps.report@gmx.net>

Why is this suddenly failing? We have had this package for ages, it
hasn't been changed recently.

So instead of just fixing the issue, we always want to understand *why*
we started having an issue.

Do you have some details of this ?

Thomas
Peter Seiderer May 28, 2020, 9:16 p.m. UTC | #2
Hello Thomas,

On Thu, 28 May 2020 22:43:35 +0200, Thomas Petazzoni <thomas.petazzoni@bootlin.com> wrote:

> On Thu, 28 May 2020 22:32:04 +0200
> Peter Seiderer <ps.report@gmx.net> wrote:
>
> > Use ac_cv_func_working_mktime=yes to force the use of a provided
> > mktime implementation instead of compiling the failing own one.
> >
> > Fixes:
> >
> >   http://autobuild.buildroot.net/results/5bcd8f4235002da682cc900f866116d2fe87f1c8
> >
> >   mktime.c: In function 'ydhms_diff':
> >   mktime.c:106:52: error: size of array 'a' is negative
> >    #define verify(name, assertion) struct name { char a[(assertion) ? 1 : -1]; }
> >                                                       ^
> >   mktime.c:170:3: note: in expansion of macro 'verify'
> >      verify (long_int_year_and_yday_are_wide_enough,
> >      ^~~~~~
> >
> > Signed-off-by: Peter Seiderer <ps.report@gmx.net>
>
> Why is this suddenly failing? We have had this package for ages, it
> hasn't been changed recently.
>
> So instead of just fixing the issue, we always want to understand *why*
> we started having an issue.
>
> Do you have some details of this ?

Sorry for being (too) short in the commit log, the failure/assert comes from the lines:

  verify (long_int_year_and_yday_are_wide_enough,
          INT_MAX <= LONG_MAX / 2 || TIME_T_MAX <= UINT_MAX);

And happens with musl libc, I believe another fail out from the y2038
time_t conversion from 32bit to 64bit...

Regards,
Peter

>
> Thomas
Thomas Petazzoni May 28, 2020, 9:29 p.m. UTC | #3
On Thu, 28 May 2020 23:16:49 +0200
Peter Seiderer <ps.report@gmx.net> wrote:

> Sorry for being (too) short in the commit log, the failure/assert comes from the lines:
> 
>   verify (long_int_year_and_yday_are_wide_enough,
>           INT_MAX <= LONG_MAX / 2 || TIME_T_MAX <= UINT_MAX);
> 
> And happens with musl libc, I believe another fail out from the y2038
> time_t conversion from 32bit to 64bit...

So it's happening since the upgrade of musl to musl 1.2.0 ?

And yes, a more detailed commit log would be good. Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/cvs/cvs.mk b/package/cvs/cvs.mk
index 563802cc9d..6f83ca6408 100644
--- a/package/cvs/cvs.mk
+++ b/package/cvs/cvs.mk
@@ -12,7 +12,9 @@  CVS_LICENSE = GPL-1.0+, LGPL-2.0+, LGPL-2.1+ (glob)
 CVS_LICENSE_FILES = COPYING COPYING.LIB lib/glob-libc.h
 CVS_DEPENDENCIES = ncurses
 
-CVS_CONF_ENV = cvs_cv_func_printf_ptr=yes
+CVS_CONF_ENV = \
+	ac_cv_func_working_mktime=yes \
+	cvs_cv_func_printf_ptr=yes
 
 CVS_CONFIGURE_ARGS = --disable-old-info-format-support
 ifeq ($(BR2_PACKAGE_CVS_SERVER),y)