diff mbox series

[3/3] package/sdl2: enable 3DNOW only if it's supported by the target

Message ID 20200515175357.45954-3-nrosfs@gmail.com
State Accepted
Headers show
Series [1/3] package/sdl2: enable SSE only if it's supported by the target | expand

Commit Message

Nicolas Robin May 15, 2020, 5:53 p.m. UTC
Signed-off-by: Nicolas Robin <nrosfs@gmail.com>
---
 package/sdl2/sdl2.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Peter Korsgaard July 16, 2020, 4:18 p.m. UTC | #1
>>>>> "Nicolas" == Nicolas Robin <nrosfs@gmail.com> writes:

 > Signed-off-by: Nicolas Robin <nrosfs@gmail.com>

Committed to 2020.02.x and 2020.05.x, thanks.
diff mbox series

Patch

diff --git a/package/sdl2/sdl2.mk b/package/sdl2/sdl2.mk
index 4a287b66a3..830873c9e4 100644
--- a/package/sdl2/sdl2.mk
+++ b/package/sdl2/sdl2.mk
@@ -36,6 +36,12 @@  else
 SDL2_CONF_OPTS += --disable-sse
 endif
 
+ifeq ($(BR2_X86_CPU_HAS_3DNOW),y)
+SDL2_CONF_OPTS += --enable-3dnow
+else
+SDL2_CONF_OPTS += --disable-3dnow
+endif
+
 ifeq ($(BR2_PACKAGE_SDL2_DIRECTFB),y)
 SDL2_DEPENDENCIES += directfb
 SDL2_CONF_OPTS += --enable-video-directfb