diff mbox series

[Next] package/kmod: modinfo support of signature details

Message ID 20200514182806.56592-1-matthew.weber@rockwellcollins.com
State Accepted
Headers show
Series [Next] package/kmod: modinfo support of signature details | expand

Commit Message

Matt Weber May 14, 2020, 6:28 p.m. UTC
Add conditional support to allow the module tools to use openssl
on target to inspect the signature of signed modules. If openssl
is not enabled the modinfo will show a hash algo as unknown.

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
---
Prior to this patch the kmod series for compressed modules should
be applied. No functionality dependency, I just identified them as
patching conflicts.

http://patchwork.ozlabs.org/project/buildroot/list/?series=174301
---
 package/kmod/kmod.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Yann E. MORIN May 15, 2020, 8:19 p.m. UTC | #1
Matt, All,

On 2020-05-14 13:28 -0500, Matt Weber spake thusly:
> Add conditional support to allow the module tools to use openssl
> on target to inspect the signature of signed modules. If openssl
> is not enabled the modinfo will show a hash algo as unknown.
> 
> Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>

Tested-by: Yann E. MORIN <yann.morin.1998@free.fr>
Acked-by: Yann E. MORIN <yann.morin.1998@free.fr>

You tagged it for next, but I think we can see that as a fix, as it
at least ensures build order when enabled, and explicit disabling
otherwise.

Regards,
Yann E. MORIN.

> ---
> Prior to this patch the kmod series for compressed modules should
> be applied. No functionality dependency, I just identified them as
> patching conflicts.
> 
> http://patchwork.ozlabs.org/project/buildroot/list/?series=174301
> ---
>  package/kmod/kmod.mk | 7 +++++++
>  1 file changed, 7 insertions(+)
> 
> diff --git a/package/kmod/kmod.mk b/package/kmod/kmod.mk
> index 979c3e87e6..69615452cf 100644
> --- a/package/kmod/kmod.mk
> +++ b/package/kmod/kmod.mk
> @@ -46,6 +46,13 @@ else
>  KMOD_CONF_OPTS += --without-xz
>  endif
>  
> +ifeq ($(BR2_PACKAGE_OPENSSL),y)
> +KMOD_DEPENDENCIES += openssl
> +KMOD_CONF_OPTS += --with-openssl
> +else
> +KMOD_CONF_OPTS += --without-openssl
> +endif
> +
>  ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
>  KMOD_DEPENDENCIES += $(if $(BR2_PACKAGE_PYTHON),python,python3)
>  KMOD_CONF_OPTS += --enable-python
> -- 
> 2.17.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Yann E. MORIN May 15, 2020, 9 p.m. UTC | #2
Matt, All,

On 2020-05-15 22:19 +0200, Yann E. MORIN spake thusly:
> On 2020-05-14 13:28 -0500, Matt Weber spake thusly:
> > Add conditional support to allow the module tools to use openssl
> > on target to inspect the signature of signed modules. If openssl
> > is not enabled the modinfo will show a hash algo as unknown.
> > 
> > Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
> 
> Tested-by: Yann E. MORIN <yann.morin.1998@free.fr>
> Acked-by: Yann E. MORIN <yann.morin.1998@free.fr>
> 
> You tagged it for next, but I think we can see that as a fix, as it
> at least ensures build order when enabled, and explicit disabling
> otherwise.

So I applied to master, thanks.

Regards,
Yann E. MORIN.

> Regards,
> Yann E. MORIN.
> 
> > ---
> > Prior to this patch the kmod series for compressed modules should
> > be applied. No functionality dependency, I just identified them as
> > patching conflicts.
> > 
> > http://patchwork.ozlabs.org/project/buildroot/list/?series=174301
> > ---
> >  package/kmod/kmod.mk | 7 +++++++
> >  1 file changed, 7 insertions(+)
> > 
> > diff --git a/package/kmod/kmod.mk b/package/kmod/kmod.mk
> > index 979c3e87e6..69615452cf 100644
> > --- a/package/kmod/kmod.mk
> > +++ b/package/kmod/kmod.mk
> > @@ -46,6 +46,13 @@ else
> >  KMOD_CONF_OPTS += --without-xz
> >  endif
> >  
> > +ifeq ($(BR2_PACKAGE_OPENSSL),y)
> > +KMOD_DEPENDENCIES += openssl
> > +KMOD_CONF_OPTS += --with-openssl
> > +else
> > +KMOD_CONF_OPTS += --without-openssl
> > +endif
> > +
> >  ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
> >  KMOD_DEPENDENCIES += $(if $(BR2_PACKAGE_PYTHON),python,python3)
> >  KMOD_CONF_OPTS += --enable-python
> > -- 
> > 2.17.1
> > 
> > _______________________________________________
> > buildroot mailing list
> > buildroot@busybox.net
> > http://lists.busybox.net/mailman/listinfo/buildroot
> 
> -- 
> .-----------------.--------------------.------------------.--------------------.
> |  Yann E. MORIN  | Real-Time Embedded | /"\ ASCII RIBBON | Erics' conspiracy: |
> | +33 662 376 056 | Software  Designer | \ / CAMPAIGN     |  ___               |
> | +33 561 099 427 `------------.-------:  X  AGAINST      |  \e/  There is no  |
> | http://ymorin.is-a-geek.org/ | _/*\_ | / \ HTML MAIL    |   v   conspiracy.  |
> '------------------------------^-------^------------------^--------------------'
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/kmod/kmod.mk b/package/kmod/kmod.mk
index 979c3e87e6..69615452cf 100644
--- a/package/kmod/kmod.mk
+++ b/package/kmod/kmod.mk
@@ -46,6 +46,13 @@  else
 KMOD_CONF_OPTS += --without-xz
 endif
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+KMOD_DEPENDENCIES += openssl
+KMOD_CONF_OPTS += --with-openssl
+else
+KMOD_CONF_OPTS += --without-openssl
+endif
+
 ifeq ($(BR2_PACKAGE_PYTHON)$(BR2_PACKAGE_PYTHON3),y)
 KMOD_DEPENDENCIES += $(if $(BR2_PACKAGE_PYTHON),python,python3)
 KMOD_CONF_OPTS += --enable-python