diff mbox series

[1/1] package/minidlna: fix build with musl-1.2.0

Message ID 20200503075312.703486-1-bernd.kuhls@t-online.de
State Not Applicable
Headers show
Series [1/1] package/minidlna: fix build with musl-1.2.0 | expand

Commit Message

Bernd Kuhls May 3, 2020, 7:53 a.m. UTC
Fixes:
http://autobuild.buildroot.net/results/31b/31bf9814a5a45081cf58675a9f7fa7183b4ef0bf/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 ...nistd.h-include-to-fix-build-with-mu.patch | 34 +++++++++++++++++++
 1 file changed, 34 insertions(+)
 create mode 100644 package/minidlna/0001-uuid.c-add-asm-unistd.h-include-to-fix-build-with-mu.patch

Comments

Thomas Petazzoni May 9, 2020, 9:30 p.m. UTC | #1
On Sun,  3 May 2020 09:53:12 +0200
Bernd Kuhls <bernd.kuhls@t-online.de> wrote:

> diff --git a/package/minidlna/0001-uuid.c-add-asm-unistd.h-include-to-fix-build-with-mu.patch b/package/minidlna/0001-uuid.c-add-asm-unistd.h-include-to-fix-build-with-mu.patch
> new file mode 100644
> index 0000000000..5e64103c34
> --- /dev/null
> +++ b/package/minidlna/0001-uuid.c-add-asm-unistd.h-include-to-fix-build-with-mu.patch
> @@ -0,0 +1,34 @@
> +From 9e21f3f91195a7c4a73ebf112823f7dbb94732db Mon Sep 17 00:00:00 2001
> +From: Bernd Kuhls <bernd.kuhls@t-online.de>
> +Date: Sun, 3 May 2020 09:42:57 +0200
> +Subject: [PATCH] uuid.c: add asm/unistd.h include to fix build with
> + musl-1.2.0
> +
> +Build was broken due to musl commit
> +https://git.musl-libc.org/cgit/musl/commit/?id=5a105f19b5aae79dd302899e634b6b18b3dcd0d6
> +
> +To fix also include asm/unistd.h following the configure.ac check for
> +the __NR_clock_gettime syscall.
> +
> +Patch sent upstream: https://sourceforge.net/p/minidlna/patches/182/
> +
> +Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> +---
> + uuid.c | 1 +
> + 1 file changed, 1 insertion(+)
> +
> +diff --git a/uuid.c b/uuid.c
> +index 6e6a9ec..78f110c 100644
> +--- a/uuid.c
> ++++ b/uuid.c
> +@@ -36,6 +36,7 @@
> + #if HAVE_MACH_MACH_TIME_H
> + #include <mach/mach_time.h>
> + #elif HAVE_CLOCK_GETTIME_SYSCALL
> ++#include <asm/unistd.h>

I am not an expert with all the time changes in the kernel/libc, but
this seems quite wrong:

 (1) Including <asm/...> headers should typically not be done

 (2) The commit at
     https://git.musl-libc.org/cgit/musl/commit/?id=5a105f19b5aae79dd302899e634b6b18b3dcd0d6
     says:

this patch renames the syscalls on 32-bit archs to clock_gettime32 and
gettimeofday_time32, so that applications using the original names
will fail to build without being fixed.

     So the breakage is intentional, and it should be fixed in the
     application.

So the big question is why does minidlna wants to do the syscall
directly instead of using clock_gettime(), which is the right thing to
do ?

Best regards,

Thomas
Bernd Kuhls May 10, 2020, 10:19 a.m. UTC | #2
Am Sat, 09 May 2020 23:30:34 +0200 schrieb Thomas Petazzoni:

> So the big question is why does minidlna wants to do the syscall
> directly instead of using clock_gettime(), which is the right thing to
> do ?

Hi Thomas,

no idea, let's wait for an upstream reponse to my patch.

Regards, Bernd
Thomas Petazzoni Jan. 9, 2021, 10:06 p.m. UTC | #3
On Sun,  3 May 2020 09:53:12 +0200
Bernd Kuhls <bernd.kuhls@t-online.de> wrote:

> Fixes:
> http://autobuild.buildroot.net/results/31b/31bf9814a5a45081cf58675a9f7fa7183b4ef0bf/
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

minidlna now builds fine with musl: since we bumped to minidlna 1.3.0,
there are no longer any failures in the autobuilders on minidlna.

And indeed, upstream commit 347aafa6d7275cbb44963f10cf4d12168bc3cb8c
was made to fix musl issues.

So I've marked this patch as not applicable.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/minidlna/0001-uuid.c-add-asm-unistd.h-include-to-fix-build-with-mu.patch b/package/minidlna/0001-uuid.c-add-asm-unistd.h-include-to-fix-build-with-mu.patch
new file mode 100644
index 0000000000..5e64103c34
--- /dev/null
+++ b/package/minidlna/0001-uuid.c-add-asm-unistd.h-include-to-fix-build-with-mu.patch
@@ -0,0 +1,34 @@ 
+From 9e21f3f91195a7c4a73ebf112823f7dbb94732db Mon Sep 17 00:00:00 2001
+From: Bernd Kuhls <bernd.kuhls@t-online.de>
+Date: Sun, 3 May 2020 09:42:57 +0200
+Subject: [PATCH] uuid.c: add asm/unistd.h include to fix build with
+ musl-1.2.0
+
+Build was broken due to musl commit
+https://git.musl-libc.org/cgit/musl/commit/?id=5a105f19b5aae79dd302899e634b6b18b3dcd0d6
+
+To fix also include asm/unistd.h following the configure.ac check for
+the __NR_clock_gettime syscall.
+
+Patch sent upstream: https://sourceforge.net/p/minidlna/patches/182/
+
+Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
+---
+ uuid.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/uuid.c b/uuid.c
+index 6e6a9ec..78f110c 100644
+--- a/uuid.c
++++ b/uuid.c
+@@ -36,6 +36,7 @@
+ #if HAVE_MACH_MACH_TIME_H
+ #include <mach/mach_time.h>
+ #elif HAVE_CLOCK_GETTIME_SYSCALL
++#include <asm/unistd.h>
+ #include <sys/syscall.h>
+ #endif
+ 
+-- 
+2.26.2
+