diff mbox series

[v2,1/2] package/vala: install wrapper to vapigen

Message ID 20200323175813.3903868-1-aduskett@gmail.com
State Changes Requested
Headers show
Series [v2,1/2] package/vala: install wrapper to vapigen | expand

Commit Message

Adam Duskett March 23, 2020, 5:58 p.m. UTC
From: Adam Duskett <Aduskett@gmail.com>

when compiling gobject-introspection .gir files, some packages use vapigen to
generate a vala-api compatible .gir file. These packages tend to call vapigen
directly instead of vala or valac.

Without the wrapper, building the .gir files fail. In the case of for example,
gupnp-dlna throws the following error:
"error: Package `Gst-1.0' not found in specified Vala API directories or
GObject-Introspection GIR directories."

Installing the vala wrapper to vapigen fixes the above issue.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
---
Changes v1 -> v2:
  - Add this patch to the series.

 package/vala/vala.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Adam Duskett March 23, 2020, 6:04 p.m. UTC | #1
All;

On Mon, Mar 23, 2020 at 10:58 AM <aduskett@gmail.com> wrote:
>
> From: Adam Duskett <Aduskett@gmail.com>
>
> when compiling gobject-introspection .gir files, some packages use vapigen to
> generate a vala-api compatible .gir file. These packages tend to call vapigen
> directly instead of vala or valac.
>
> Without the wrapper, building the .gir files fail. In the case of for example,
> gupnp-dlna throws the following error:
> "error: Package `Gst-1.0' not found in specified Vala API directories or
> GObject-Introspection GIR directories."
>
> Installing the vala wrapper to vapigen fixes the above issue.
>
> Signed-off-by: Adam Duskett <Aduskett@gmail.com>
> ---
> Changes v1 -> v2:
>   - Add this patch to the series.
>
>  package/vala/vala.mk | 4 +++-
>  1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/package/vala/vala.mk b/package/vala/vala.mk
> index b8a69f8c5e..d000393d71 100644
> --- a/package/vala/vala.mk
> +++ b/package/vala/vala.mk
> @@ -17,13 +17,15 @@ HOST_VALA_DEPENDENCIES = host-bison host-flex host-libglib2
>  HOST_VALA_CONF_ENV = ac_cv_path_XSLTPROC=:
>  HOST_VALA_CONF_OPTS += --disable-valadoc
>
> -# We wrap vala & valac to point to the proper gir and vapi data dirs
> +# We wrap vala, valac and vapigen to point to the proper gir and vapi data dirs
>  # Otherwise we'll get host directory data which isn't enough
>  define HOST_VALA_INSTALL_WRAPPER
>         $(INSTALL) -D -m 0755 package/vala/vala-wrapper \
>                 $(HOST_DIR)/bin/vala
>         $(INSTALL) -D -m 0755 package/vala/vala-wrapper \
>                 $(HOST_DIR)/bin/valac
> +       $(INSTALL) -D -m 0755 package/vala/vala-wrapper \
> +               $(HOST_DIR)/bin/vapigen
>         $(SED) 's,@VALA_VERSION@,$(VALA_VERSION_MAJOR),' \
>                 $(HOST_DIR)/bin/vala \
>                 $(HOST_DIR)/bin/valac
I added vapigen to this line but didn't save the .mk file before
committing. If you want me to resend
a new patch with $(HOST_DIR)/bin/vapigen please let me know!

Adam
> --
> 2.25.1
>
diff mbox series

Patch

diff --git a/package/vala/vala.mk b/package/vala/vala.mk
index b8a69f8c5e..d000393d71 100644
--- a/package/vala/vala.mk
+++ b/package/vala/vala.mk
@@ -17,13 +17,15 @@  HOST_VALA_DEPENDENCIES = host-bison host-flex host-libglib2
 HOST_VALA_CONF_ENV = ac_cv_path_XSLTPROC=:
 HOST_VALA_CONF_OPTS += --disable-valadoc
 
-# We wrap vala & valac to point to the proper gir and vapi data dirs
+# We wrap vala, valac and vapigen to point to the proper gir and vapi data dirs
 # Otherwise we'll get host directory data which isn't enough
 define HOST_VALA_INSTALL_WRAPPER
 	$(INSTALL) -D -m 0755 package/vala/vala-wrapper \
 		$(HOST_DIR)/bin/vala
 	$(INSTALL) -D -m 0755 package/vala/vala-wrapper \
 		$(HOST_DIR)/bin/valac
+	$(INSTALL) -D -m 0755 package/vala/vala-wrapper \
+		$(HOST_DIR)/bin/vapigen
 	$(SED) 's,@VALA_VERSION@,$(VALA_VERSION_MAJOR),' \
 		$(HOST_DIR)/bin/vala \
 		$(HOST_DIR)/bin/valac