diff mbox series

[1/1] package/civetweb: add zlib optional dependency

Message ID 20200317211457.1272741-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/civetweb: add zlib optional dependency | expand

Commit Message

Fabrice Fontaine March 17, 2020, 9:14 p.m. UTC
zlib is an optional dependency since version 1.11 and
https://github.com/civetweb/civetweb/commit/6b8b15935378f71323ff95f907fa0d33841deac0

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/civetweb/civetweb.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Thomas Petazzoni March 21, 2020, 3:57 p.m. UTC | #1
On Tue, 17 Mar 2020 22:14:57 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> zlib is an optional dependency since version 1.11 and
> https://github.com/civetweb/civetweb/commit/6b8b15935378f71323ff95f907fa0d33841deac0
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/civetweb/civetweb.mk | 6 ++++++
>  1 file changed, 6 insertions(+)

Applied to master, thanks.

Thomas
Peter Korsgaard April 6, 2020, 4:17 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > zlib is an optional dependency since version 1.11 and
 > https://github.com/civetweb/civetweb/commit/6b8b15935378f71323ff95f907fa0d33841deac0

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2019.02.x, 2019.11.x and 2020.02.x, thanks.
diff mbox series

Patch

diff --git a/package/civetweb/civetweb.mk b/package/civetweb/civetweb.mk
index 99da1b6f06..f05b29f3cd 100644
--- a/package/civetweb/civetweb.mk
+++ b/package/civetweb/civetweb.mk
@@ -38,6 +38,12 @@  else
 CIVETWEB_COPT += -DNO_SSL
 endif
 
+ifeq ($(BR2_PACKAGE_ZLIB),y)
+CIVETWEB_CONF_OPTS += WITH_ZLIB=1
+CIVETWEB_LIBS += -lz
+CIVETWEB_DEPENDENCIES += zlib
+endif
+
 ifeq ($(BR2_PACKAGE_CIVETWEB_SERVER),y)
 CIVETWEB_BUILD_TARGETS += build
 CIVETWEB_INSTALL_TARGETS += install