diff mbox series

[v2,2/2] package/libglib2: restore use of system printf

Message ID 20200311112256.2849174-2-john@metanate.com
State Accepted
Headers show
Series None | expand

Commit Message

John Keeping March 11, 2020, 11:22 a.m. UTC
Prior to commit 4102db0f7a ("package/libglib2: bump to version 2.60.3")
which converted libglib2 to meson, Buildroot used to set a range of
autoconf options to bypass tests that require running binaries.

The meson version of libglib2's build system has many fewer of these
checks, but there are still some and these can be fed the "correct"
answer by adding properties to cross-compilation.conf.

Add the necessary properties to indicate that we have C99 compliant
print functions to avoid pulling in the gnulib fallback.

Signed-off-by: John Keeping <john@metanate.com>
Reviewed-by: Peter Seiderer <ps.report@gmx.net>
---
v2:
- Add Peter's reviewed-by - thanks!
---
 package/libglib2/libglib2.mk | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Thomas Petazzoni April 21, 2020, 8:51 p.m. UTC | #1
On Wed, 11 Mar 2020 11:22:56 +0000
John Keeping <john@metanate.com> wrote:

> Prior to commit 4102db0f7a ("package/libglib2: bump to version 2.60.3")
> which converted libglib2 to meson, Buildroot used to set a range of
> autoconf options to bypass tests that require running binaries.
> 
> The meson version of libglib2's build system has many fewer of these
> checks, but there are still some and these can be fed the "correct"
> answer by adding properties to cross-compilation.conf.
> 
> Add the necessary properties to indicate that we have C99 compliant
> print functions to avoid pulling in the gnulib fallback.
> 
> Signed-off-by: John Keeping <john@metanate.com>
> Reviewed-by: Peter Seiderer <ps.report@gmx.net>
> ---
> v2:
> - Add Peter's reviewed-by - thanks!
> ---
>  package/libglib2/libglib2.mk | 5 +++++
>  1 file changed, 5 insertions(+)

Applied to master, thanks.

Thomas
Peter Korsgaard May 8, 2020, 7:15 a.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@bootlin.com> writes:

 > On Wed, 11 Mar 2020 11:22:56 +0000
 > John Keeping <john@metanate.com> wrote:

 >> Prior to commit 4102db0f7a ("package/libglib2: bump to version 2.60.3")
 >> which converted libglib2 to meson, Buildroot used to set a range of
 >> autoconf options to bypass tests that require running binaries.
 >> 
 >> The meson version of libglib2's build system has many fewer of these
 >> checks, but there are still some and these can be fed the "correct"
 >> answer by adding properties to cross-compilation.conf.
 >> 
 >> Add the necessary properties to indicate that we have C99 compliant
 >> print functions to avoid pulling in the gnulib fallback.
 >> 
 >> Signed-off-by: John Keeping <john@metanate.com>
 >> Reviewed-by: Peter Seiderer <ps.report@gmx.net>
 >> ---
 >> v2:
 >> - Add Peter's reviewed-by - thanks!
 >> ---
 >> package/libglib2/libglib2.mk | 5 +++++
 >> 1 file changed, 5 insertions(+)

 > Applied to master, thanks.

Committed to 2020.02.x, thanks.
diff mbox series

Patch

diff --git a/package/libglib2/libglib2.mk b/package/libglib2/libglib2.mk
index f00818f69c..a206639f74 100644
--- a/package/libglib2/libglib2.mk
+++ b/package/libglib2/libglib2.mk
@@ -52,6 +52,11 @@  LIBGLIB2_CONF_OPTS = \
 	-Dinstalled_tests=false \
 	-Doss_fuzz=disabled
 
+LIBGLIB2_MESON_EXTRA_PROPERTIES = \
+	have_c99_vsnprintf=true \
+	have_c99_snprintf=true \
+	have_unix98_printf=true
+
 ifneq ($(BR2_ENABLE_LOCALE),y)
 LIBGLIB2_DEPENDENCIES += libiconv
 endif