diff mbox series

[6/7] package/qt5: generalize the condition on which EGLFS KMS gets supported

Message ID 20200306071440.30433-7-miquel.raynal@bootlin.com
State Superseded
Headers show
Series [1/7] package/sunxi-mali-utgard: rename from sunxi-mali-mainline | expand

Commit Message

Miquel Raynal March 6, 2020, 7:14 a.m. UTC
BR2_PACKAGE_HAS_LIBEGL indicates that the virtual libegl packet is
enabled. This packet may be provided by mesa3d (this is actually what
happens when selecting BR2_PACKAGE_MESA3D_OPENGL_EGL) but
other providers may exist.

Generalize the condition on which EGLFS KMS support is added to Qt5 to
allow rockchip-mali-bifrost (and potentially other) to use the KMS
back-end.

Suggested-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com>
---
 package/qt5/qt5base/qt5base.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Jan. 8, 2022, 6:12 p.m. UTC | #1
On Fri,  6 Mar 2020 08:14:39 +0100
Miquel Raynal <miquel.raynal@bootlin.com> wrote:

> BR2_PACKAGE_HAS_LIBEGL indicates that the virtual libegl packet is
> enabled. This packet may be provided by mesa3d (this is actually what
> happens when selecting BR2_PACKAGE_MESA3D_OPENGL_EGL) but
> other providers may exist.
> 
> Generalize the condition on which EGLFS KMS support is added to Qt5 to
> allow rockchip-mali-bifrost (and potentially other) to use the KMS
> back-end.
> 
> Suggested-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com>
> ---
>  package/qt5/qt5base/qt5base.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

This is no longer needed since commit
469829d9c55b7f5461e29f3f6436417836504410. All that conditional logic to
determine which Qt libraries and plugins to install is gone, as we now
use the Qt "make install" logic.

So I'll mark this patch as Superseded.

Thomas
diff mbox series

Patch

diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index 8803a4821e..ad01c7c843 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -295,7 +295,7 @@  QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_XML)        += Qt5Xml
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_OPENGL_LIB) += Qt5OpenGL
 ifeq ($(BR2_PACKAGE_QT5_VERSION_LATEST),y)
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_EGLFS)      += Qt5EglFSDeviceIntegration
-ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_EGL),y)
+ifeq ($(BR2_PACKAGE_HAS_LIBEGL),y)
 QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_EGLFS)      += Qt5EglFsKmsSupport
 endif
 ifeq ($(BR2_PACKAGE_GCNANO_BINARIES),y)