diff mbox series

[4/5] package/sdl2_mixer: add optional fluidsynth dependency

Message ID 20200110220239.196975-4-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/5] package/fluidsynth: install to staging | expand

Commit Message

Fabrice Fontaine Jan. 10, 2020, 10:02 p.m. UTC
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/sdl2_mixer/sdl2_mixer.mk | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/package/sdl2_mixer/sdl2_mixer.mk b/package/sdl2_mixer/sdl2_mixer.mk
index 198333854e..34bba5772d 100644
--- a/package/sdl2_mixer/sdl2_mixer.mk
+++ b/package/sdl2_mixer/sdl2_mixer.mk
@@ -12,9 +12,7 @@  SDL2_MIXER_LICENSE_FILES = COPYING.txt
 SDL2_MIXER_INSTALL_STAGING = YES
 SDL2_MIXER_DEPENDENCIES = sdl2 host-pkgconf
 
-SDL2_MIXER_CONF_OPTS = \
-	--disable-music-midi-fluidsynth \
-	--disable-music-mp3
+SDL2_MIXER_CONF_OPTS = --disable-music-mp3
 
 ifeq ($(BR2_PACKAGE_FLAC),y)
 SDL2_MIXER_CONF_OPTS += --enable-music-flac
@@ -23,6 +21,13 @@  else
 SDL2_MIXER_CONF_OPTS += --disable-music-flac
 endif
 
+ifeq ($(BR2_PACKAGE_FLUIDSYNTH),y)
+SDL2_MIXER_CONF_OPTS += --enable-music-midi-fluidsynth
+SDL2_MIXER_DEPENDENCIES += fluidsynth
+else
+SDL2_MIXER_CONF_OPTS += --disable-music-midi-fluidsynth
+endif
+
 ifeq ($(BR2_PACKAGE_LIBMODPLUG),y)
 SDL2_MIXER_CONF_OPTS += --enable-music-mod-modplug
 SDL2_MIXER_DEPENDENCIES += libmodplug