diff mbox series

package/libuio: add missing dependency on host-pkgconf

Message ID 20191210221022.948846-1-thomas.petazzoni@bootlin.com
State Accepted
Headers show
Series package/libuio: add missing dependency on host-pkgconf | expand

Commit Message

Thomas Petazzoni Dec. 10, 2019, 10:10 p.m. UTC
configure fails if the pkgconfig.m4 macros are not available during
this package autoreconf:

./configure: line 12003: syntax error near unexpected token `PKGCONF,'
./configure: line 12003: `   PKG_CHECK_MODULES(PKGCONF, glib-2.0)

Fixes:

  http://autobuild.buildroot.net/results/9be944e35090bf270fbc9572423466be9af7b1f2/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/libuio/libuio.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Dec. 12, 2019, 7:28 a.m. UTC | #1
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@bootlin.com> writes:

 > configure fails if the pkgconfig.m4 macros are not available during
 > this package autoreconf:

 > ./configure: line 12003: syntax error near unexpected token `PKGCONF,'
 > ./configure: line 12003: `   PKG_CHECK_MODULES(PKGCONF, glib-2.0)

 > Fixes:

 >   http://autobuild.buildroot.net/results/9be944e35090bf270fbc9572423466be9af7b1f2/

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Committed, thanks.
Peter Korsgaard Dec. 22, 2019, 9:01 p.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@bootlin.com> writes:

 > configure fails if the pkgconfig.m4 macros are not available during
 > this package autoreconf:

 > ./configure: line 12003: syntax error near unexpected token `PKGCONF,'
 > ./configure: line 12003: `   PKG_CHECK_MODULES(PKGCONF, glib-2.0)

 > Fixes:

 >   http://autobuild.buildroot.net/results/9be944e35090bf270fbc9572423466be9af7b1f2/

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Committed to 2019.02.x and 2019.11.x, thanks.
diff mbox series

Patch

diff --git a/package/libuio/libuio.mk b/package/libuio/libuio.mk
index 13429ec0f1..b6e8e7e774 100644
--- a/package/libuio/libuio.mk
+++ b/package/libuio/libuio.mk
@@ -10,7 +10,7 @@  LIBUIO_SITE = $(call github,Linutronix,libuio,$(LIBUIO_VERSION))
 LIBUIO_LICENSE = LGPL-2.1 (library), GPL-2.0 (programs)
 LIBUIO_LICENSE_FILES = COPYING
 LIBUIO_CONF_OPTS = --with-glib=no --without-werror
-LIBUIO_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
+LIBUIO_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES) host-pkgconf
 LIBUIO_LIBS = $(TARGET_NLS_LIBS)
 LIBUIO_INSTALL_STAGING = YES