diff mbox series

[2/3] package/dante: add optional libminiupnpc dependency

Message ID 20191209222746.3440986-2-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series None | expand

Commit Message

Fabrice Fontaine Dec. 9, 2019, 10:27 p.m. UTC
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/dante/dante.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Peter Korsgaard Dec. 12, 2019, 7:46 a.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/dante/dante.mk b/package/dante/dante.mk
index 0668042bd8..35b785dc70 100644
--- a/package/dante/dante.mk
+++ b/package/dante/dante.mk
@@ -14,6 +14,13 @@  DANTE_AUTORECONF = YES
 
 DANTE_CONF_OPTS += --disable-client --disable-preload
 
+ifeq ($(BR2_PACKAGE_LIBMINIUPNPC),y)
+DANTE_DEPENDENCIES += libminiupnpc
+DANTE_CONF_OPTS += --with-upnp
+else
+DANTE_CONF_OPTS += --without-upnp
+endif
+
 ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
 DANTE_DEPENDENCIES += linux-pam
 DANTE_CONF_OPTS += --with-pam