diff mbox series

package/python-django: security bump to version 2.2.8

Message ID 20191202122354.1700-1-peter@korsgaard.com
State Accepted
Headers show
Series package/python-django: security bump to version 2.2.8 | expand

Commit Message

Peter Korsgaard Dec. 2, 2019, 12:23 p.m. UTC
Fixes the following security vulnerabilities:

- CVE-2019-19118: Privilege escalation in the Django admin

Additionally, 2.2.8 (and 2.2.7) fixes a number of bugs and adds python 3.8
support.

For more details, see the release notes:
https://docs.djangoproject.com/en/dev/releases/2.2.8/

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
 package/python-django/python-django.hash | 4 ++--
 package/python-django/python-django.mk   | 4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

Comments

Peter Korsgaard Dec. 2, 2019, 9:23 p.m. UTC | #1
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Fixes the following security vulnerabilities:
 > - CVE-2019-19118: Privilege escalation in the Django admin

 > Additionally, 2.2.8 (and 2.2.7) fixes a number of bugs and adds python 3.8
 > support.

 > For more details, see the release notes:
 > https://docs.djangoproject.com/en/dev/releases/2.2.8/

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed, thanks.
Peter Korsgaard Dec. 6, 2019, 8:26 a.m. UTC | #2
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Fixes the following security vulnerabilities:
 > - CVE-2019-19118: Privilege escalation in the Django admin

 > Additionally, 2.2.8 (and 2.2.7) fixes a number of bugs and adds python 3.8
 > support.

 > For more details, see the release notes:
 > https://docs.djangoproject.com/en/dev/releases/2.2.8/

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed to 2019.08.x, thanks.

2019.02.x is on 2.1.x, so I will there instead bump to 2.1.5.
Peter Korsgaard Dec. 6, 2019, 8:59 a.m. UTC | #3
>>>>> "Peter" == Peter Korsgaard <peter@korsgaard.com> writes:

 > Fixes the following security vulnerabilities:
 > - CVE-2019-19118: Privilege escalation in the Django admin

 > Additionally, 2.2.8 (and 2.2.7) fixes a number of bugs and adds python 3.8
 > support.

 > For more details, see the release notes:
 > https://docs.djangoproject.com/en/dev/releases/2.2.8/

 > Signed-off-by: Peter Korsgaard <peter@korsgaard.com>

Committed to 2019.11.x, thanks.
diff mbox series

Patch

diff --git a/package/python-django/python-django.hash b/package/python-django/python-django.hash
index 0e6b7b2c63..965055f47d 100644
--- a/package/python-django/python-django.hash
+++ b/package/python-django/python-django.hash
@@ -1,5 +1,5 @@ 
 # md5, sha256 from https://pypi.org/pypi/django/json
-md5	796c175a2f94e938c60d84b4565216af  Django-2.2.6.tar.gz
-sha256	a8ca1033acac9f33995eb2209a6bf18a4681c3e5269a878e9a7e0b7384ed1ca3  Django-2.2.6.tar.gz
+md5	57d965818410a4e00e2267eef66aa9c9  Django-2.2.8.tar.gz
+sha256	a4ad4f6f9c6a4b7af7e2deec8d0cbff28501852e5010d6c2dc695d3d1fae7ca0  Django-2.2.8.tar.gz
 # Locally computed sha256 checksums
 sha256	b846415d1b514e9c1dff14a22deb906d794bc546ca6129f950a18cd091e2a669  LICENSE
diff --git a/package/python-django/python-django.mk b/package/python-django/python-django.mk
index 1c810b8af7..d541a2c07b 100644
--- a/package/python-django/python-django.mk
+++ b/package/python-django/python-django.mk
@@ -4,10 +4,10 @@ 
 #
 ################################################################################
 
-PYTHON_DJANGO_VERSION = 2.2.6
+PYTHON_DJANGO_VERSION = 2.2.8
 PYTHON_DJANGO_SOURCE = Django-$(PYTHON_DJANGO_VERSION).tar.gz
 # The official Django site has an unpractical URL
-PYTHON_DJANGO_SITE = https://files.pythonhosted.org/packages/c7/2c/bbd0fddf6a08456c3100b8e8b230f3288d4511985aa4e2368b0d115b5aae
+PYTHON_DJANGO_SITE = https://files.pythonhosted.org/packages/1c/aa/f618f346b895123be44739b276099a2b418b45b2b7afb5e1071403e8d2e9
 PYTHON_DJANGO_LICENSE = BSD-3-Clause
 PYTHON_DJANGO_LICENSE_FILES = LICENSE
 PYTHON_DJANGO_SETUP_TYPE = setuptools