diff mbox series

[1/1] package/piglit: set python executable

Message ID 20191103085520.9095-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/piglit: set python executable | expand

Commit Message

Fabrice Fontaine Nov. 3, 2019, 8:55 a.m. UTC
Without this change, piglit will detect and use python from host
resulting in build failures if python-mako, python-numpy or python-six
are not installed

Fixes:
 - http://autobuild.buildroot.org/results/8d782589b6073031626fd769982a0844f3731906

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/piglit/piglit.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Nov. 4, 2019, 9:35 p.m. UTC | #1
On Sun,  3 Nov 2019 09:55:20 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Without this change, piglit will detect and use python from host
> resulting in build failures if python-mako, python-numpy or python-six
> are not installed
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/8d782589b6073031626fd769982a0844f3731906
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/piglit/piglit.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
Romain Naour Nov. 4, 2019, 9:40 p.m. UTC | #2
Hi Fabrice,

Le 03/11/2019 à 09:55, Fabrice Fontaine a écrit :
> Without this change, piglit will detect and use python from host
> resulting in build failures if python-mako, python-numpy or python-six
> are not installed
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/8d782589b6073031626fd769982a0844f3731906
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Reviewed-by: Romain Naour <romain.naour@smile.fr>

Best regards,
Romain


> ---
>  package/piglit/piglit.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/piglit/piglit.mk b/package/piglit/piglit.mk
> index 4f95e77cfd..d4753b9f7a 100644
> --- a/package/piglit/piglit.mk
> +++ b/package/piglit/piglit.mk
> @@ -29,7 +29,8 @@ PIGLIT_DEPENDENCIES = host-pkgconf \
>  PIGLIT_CONF_OPTS += \
>  	-DPIGLIT_USE_WAFFLE=ON \
>  	-DPIGLIT_BUILD_CL_TESTS=OFF \
> -	-DPIGLIT_BUILD_WGL_TESTS=OFF
> +	-DPIGLIT_BUILD_WGL_TESTS=OFF \
> +	-DPYTHON_EXECUTABLE=$(HOST_DIR)/bin/python3
>  
>  ifeq ($(BR2_PACKAGE_XORG7),y)
>  # libxcb for xcb-dri2
>
diff mbox series

Patch

diff --git a/package/piglit/piglit.mk b/package/piglit/piglit.mk
index 4f95e77cfd..d4753b9f7a 100644
--- a/package/piglit/piglit.mk
+++ b/package/piglit/piglit.mk
@@ -29,7 +29,8 @@  PIGLIT_DEPENDENCIES = host-pkgconf \
 PIGLIT_CONF_OPTS += \
 	-DPIGLIT_USE_WAFFLE=ON \
 	-DPIGLIT_BUILD_CL_TESTS=OFF \
-	-DPIGLIT_BUILD_WGL_TESTS=OFF
+	-DPIGLIT_BUILD_WGL_TESTS=OFF \
+	-DPYTHON_EXECUTABLE=$(HOST_DIR)/bin/python3
 
 ifeq ($(BR2_PACKAGE_XORG7),y)
 # libxcb for xcb-dri2