diff mbox series

[1/1] package/znc: fix build with cmake < 3.10

Message ID 20191002175120.9238-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/znc: fix build with cmake < 3.10 | expand

Commit Message

Fabrice Fontaine Oct. 2, 2019, 5:51 p.m. UTC
Fixes:
 - http://autobuild.buildroot.org/results/991dd1d74f00f027a905d2ec3ad1a1b2b723f978

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/znc/znc.mk | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Bernd Kuhls Oct. 2, 2019, 6:11 p.m. UTC | #1
Am Wed, 02 Oct 2019 19:51:20 +0200 schrieb Fabrice Fontaine:

> +# Before CMake 3.10, passing THREADS_PTHREAD_ARG=OFF was needed to

Hi,

good catch, the old cmake version was the reason why I could not 
reproduce the error here (cmake version 3.13.4).

Reviewed-by: Bernd Kuhls <bernd.kuhls@t-online.de>

Regards, Bernd
Thomas Petazzoni Oct. 2, 2019, 7:04 p.m. UTC | #2
On Wed,  2 Oct 2019 19:51:20 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Fixes:
>  - http://autobuild.buildroot.org/results/991dd1d74f00f027a905d2ec3ad1a1b2b723f978
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/znc/znc.mk | 5 +++++
>  1 file changed, 5 insertions(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/znc/znc.mk b/package/znc/znc.mk
index 78e1410b68..54dc63f4ea 100644
--- a/package/znc/znc.mk
+++ b/package/znc/znc.mk
@@ -11,6 +11,11 @@  ZNC_LICENSE_FILES = LICENSE
 ZNC_DEPENDENCIES = host-pkgconf
 ZNC_CONF_OPTS = -DWANT_CYRUS=OFF -DWANT_I18N=OFF -DWANT_PERL=OFF
 
+# Before CMake 3.10, passing THREADS_PTHREAD_ARG=OFF was needed to
+# disable a try_run() call in the FindThreads tests, which caused a
+# build failure when cross-compiling.
+ZNC_CONF_OPTS += -DTHREADS_PTHREAD_ARG=OFF
+
 ifeq ($(BR2_PACKAGE_ICU),y)
 ZNC_DEPENDENCIES += icu
 ZNC_CONF_OPTS += -DWANT_ICU=ON