diff mbox series

[1/1] package/libssh: add option to enable server support

Message ID 20190925121726.17454-1-heiko.thiery@gmail.com
State Accepted
Headers show
Series [1/1] package/libssh: add option to enable server support | expand

Commit Message

Heiko Thiery Sept. 25, 2019, 12:17 p.m. UTC
From: Heiko Thiery <heiko.thiery@kontron.com>

This patch adds Config.in option for ssh server support.

Signed-off-by: Heiko Thiery <heiko.thiery@kontron.com>
---
 package/libssh/Config.in | 9 +++++++++
 package/libssh/libssh.mk | 7 ++++++-
 2 files changed, 15 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Sept. 27, 2019, 9:02 p.m. UTC | #1
Hello,

Thanks for your contribution!

On Wed, 25 Sep 2019 14:17:26 +0200
heiko.thiery@gmail.com wrote:

> +ifeq ($(BR2_PACKAGE_LIBSSH_SERVER),y)
> +    LIBSSH_CONF_OPTS += -DWITH_SERVER=ON
> +else
> +    LIBSSH_CONF_OPTS += -DWITH_SERVER=OFF

We don't indent such lines in our coding style, as can be seen in the
rest of the file. I have fixed this and applied your patch to Buildroot
master branch.

Just curious, what is the use case for the server support in libssh ?
The INSTALL file is not very clear about what WITH_SERVER=ON provides.

Thanks!

Thomas
Heiko Thiery Sept. 28, 2019, 7:27 a.m. UTC | #2
Hi Thomas,

We don't indent such lines in our coding style, as can be seen in the
> rest of the file. I have fixed this and applied your patch to Buildroot
> master branch.
>
Ok .. thank you.


> Just curious, what is the use case for the server support in libssh ?
> The INSTALL file is not very clear about what WITH_SERVER=ON provides.
>
I need this option for a netconf server implementation (netopeer2). I will
prepare a patchset to bring also these packages.

--
Heiko
diff mbox series

Patch

diff --git a/package/libssh/Config.in b/package/libssh/Config.in
index 3dbfa7d561..a6cf1f8960 100644
--- a/package/libssh/Config.in
+++ b/package/libssh/Config.in
@@ -13,6 +13,15 @@  config BR2_PACKAGE_LIBSSH
 
 	  http://www.libssh.org/
 
+if BR2_PACKAGE_LIBSSH
+
+config BR2_PACKAGE_LIBSSH_SERVER
+	bool "server"
+	help
+	  Enable libssh server support
+
+endif
+
 comment "libssh needs a toolchain w/ dynamic library, threads"
 	depends on BR2_USE_MMU
 	depends on BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libssh/libssh.mk b/package/libssh/libssh.mk
index d5f22c29a0..71b71a8e65 100644
--- a/package/libssh/libssh.mk
+++ b/package/libssh/libssh.mk
@@ -14,12 +14,17 @@  LIBSSH_INSTALL_STAGING = YES
 LIBSSH_SUPPORTS_IN_SOURCE_BUILD = NO
 LIBSSH_CONF_OPTS = \
 	-DWITH_STACK_PROTECTOR=OFF \
-	-DWITH_SERVER=OFF \
 	-DWITH_EXAMPLES=OFF
 
 # cmake older than 3.10 require this to avoid try_run() in FindThreads
 LIBSSH_CONF_OPTS += -DTHREADS_PTHREAD_ARG=OFF
 
+ifeq ($(BR2_PACKAGE_LIBSSH_SERVER),y)
+    LIBSSH_CONF_OPTS += -DWITH_SERVER=ON
+else
+    LIBSSH_CONF_OPTS += -DWITH_SERVER=OFF
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 LIBSSH_CONF_OPTS += -DWITH_ZLIB=ON
 LIBSSH_DEPENDENCIES += zlib