diff mbox series

[16/27] package/waf: bump to version 2.0.18

Message ID 20190908161204.26761-1-chrismcc@gmail.com
State Changes Requested
Headers show
Series [01/27] package/cairo: bump to version 1.16.0 | expand

Commit Message

Christopher McCrory Sept. 8, 2019, 4:12 p.m. UTC
update _SOURCE

Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
---
 package/waf/waf.hash | 7 ++++---
 package/waf/waf.mk   | 4 ++--
 2 files changed, 6 insertions(+), 5 deletions(-)

Comments

Thomas Petazzoni Sept. 15, 2019, 7:06 p.m. UTC | #1
Hello Christopher,

On Sun,  8 Sep 2019 09:12:04 -0700
Christopher McCrory <chrismcc@gmail.com> wrote:

> update _SOURCE
> 
> Signed-off-by: Christopher McCrory <chrismcc@gmail.com>

Did you really test this patch? I don't see how it can work. See below.

> diff --git a/package/waf/waf.mk b/package/waf/waf.mk
> index 97bc2a8963..715cbe136d 100644
> --- a/package/waf/waf.mk
> +++ b/package/waf/waf.mk
> @@ -4,8 +4,8 @@
>  #
>  ################################################################################
>  
> -WAF_VERSION = 1.9.5
> -WAF_SOURCE = waf-$(WAF_VERSION)
> +WAF_VERSION = 2.0.18
> +WAF_SOURCE = waf-$(WAF_VERSION).tar.bz2

So now, you're downloading waf as a tarball. So could you explain how
the HOST_WAF_EXTRACT_CMDS can work?

It's defined as-is:

define HOST_WAF_EXTRACT_CMDS
        $(INSTALL) -D -m 0755 $(HOST_WAF_DL_DIR)/waf-$(WAF_VERSION) $(@D)/waf
endef

So obviously, it fails badly, with:

>>> host-waf 2.0.18 Extracting
/usr/bin/install -D -m 0755 /home/thomas/dl/waf/waf-2.0.18 /home/thomas/projets/buildroot/output/build/host-waf-2.0.18/waf
/usr/bin/install: cannot stat '/home/thomas/dl/waf/waf-2.0.18': No such file or directory

So either you continue to use the standalone file at
https://waf.io/waf-2.0.18 (and you can keep the current extract
commands), or you switch to the tarball as you did, but definitely the
extract/install steps need to be updated.

It's probably worth reminding that we expect contributors to test their
patches before they are submitted, at least in a minimal. I would have
preferred less than 27 version bumps on your series, but version bumps
that are actually tested :-/

Thanks,

Thomas
diff mbox series

Patch

diff --git a/package/waf/waf.hash b/package/waf/waf.hash
index 9d610b2c1e..01108f7eeb 100644
--- a/package/waf/waf.hash
+++ b/package/waf/waf.hash
@@ -1,3 +1,4 @@ 
-# Locally computed
-sha1    33d170c738ed8c92dda2945b445272972f558244                          waf-1.9.5
-sha256  101f14e0f47a6410c00b8feda094948516cd3989491c56eb8268907fcd164909  waf-1.9.5
+# Checked with https://waf.io/waf-2.0.18.tar.bz2.asc
+# with key 8AF22DE5A06822E3474F3C7049B4C67C05277AAA
+# Locally calculated
+sha256 263d7ad4a75fd278399a1eae3eff6e8256a27617b3231b48e9b8992d1b6c7064 waf-2.0.18.tar.bz2
diff --git a/package/waf/waf.mk b/package/waf/waf.mk
index 97bc2a8963..715cbe136d 100644
--- a/package/waf/waf.mk
+++ b/package/waf/waf.mk
@@ -4,8 +4,8 @@ 
 #
 ################################################################################
 
-WAF_VERSION = 1.9.5
-WAF_SOURCE = waf-$(WAF_VERSION)
+WAF_VERSION = 2.0.18
+WAF_SOURCE = waf-$(WAF_VERSION).tar.bz2
 WAF_SITE = https://waf.io
 
 define HOST_WAF_EXTRACT_CMDS