diff mbox series

[02/31] package/libva: remove optional mesa3d support

Message ID 20190630140525.6537-3-bernd.kuhls@t-online.de
State RFC
Headers show
Series package/kodi: bump to version 18.3-Leia | expand

Commit Message

Bernd Kuhls June 30, 2019, 2:04 p.m. UTC
Kodi 18.0-Leia will support vaapi on r600 and radeonsi.
We need libva support in mesa3d for this. To avoid the circular
dependency we switch from using mesa3d in libva to use libva in mesa3d.

This patch is the first step: disable mesa3d support in libva.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/libva/libva.mk | 7 ++-----
 1 file changed, 2 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/package/libva/libva.mk b/package/libva/libva.mk
index e876a1a3d0..e64f5cf392 100644
--- a/package/libva/libva.mk
+++ b/package/libva/libva.mk
@@ -15,17 +15,14 @@  LIBVA_DEPENDENCIES = host-pkgconf libdrm
 # libdrm is a hard-dependency
 LIBVA_CONF_OPTS = \
 	--enable-drm \
+	--disable-glx \
 	--with-drivers-path="/usr/lib/va"
 
 ifeq ($(BR2_PACKAGE_XORG7),y)
 LIBVA_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXfixes
 LIBVA_CONF_OPTS += --enable-x11
-ifeq ($(BR2_PACKAGE_MESA3D_DRI_DRIVER),y)
-LIBVA_DEPENDENCIES += mesa3d
-LIBVA_CONF_OPTS += --enable-glx
-endif
 else
-LIBVA_CONF_OPTS += --disable-glx --disable-x11
+LIBVA_CONF_OPTS += --disable-x11
 endif
 
 ifeq ($(BR2_PACKAGE_WAYLAND),y)