diff mbox series

[v2,1/4] package/brotli: work aroung gcc bug 68485

Message ID 20190527213826.114001-2-giulio.benetti@micronovasrl.com
State Accepted
Headers show
Series Fix and clean GCC BUG 68485 per-package | expand

Commit Message

Giulio Benetti May 27, 2019, 9:38 p.m. UTC
With Microblaze Gcc version <= 9.x the build fails due to gcc bug 68485:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68485. The bug show up when
building brotli with optimization but not when building with -O0. To
work aroung this, if BR2_TOOLCHAIN_HAS_GCC_BUG_68458=y, we force using
-O0.

Fixes:

  http://autobuild.buildroot.net/results/d86/d86251974a0a348a64d9a1d1fd7d02dd4aff0792/

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
---
 package/brotli/brotli.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Arnout Vandecappelle May 27, 2019, 10:11 p.m. UTC | #1
On 27/05/2019 23:38, Giulio Benetti wrote:
> With Microblaze Gcc version <= 9.x the build fails due to gcc bug 68485:
> https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68485. The bug show up when
> building brotli with optimization but not when building with -O0. To
> work aroung this, if BR2_TOOLCHAIN_HAS_GCC_BUG_68458=y, we force using
> -O0.
> 
> Fixes:
> 
>   http://autobuild.buildroot.net/results/d86/d86251974a0a348a64d9a1d1fd7d02dd4aff0792/
> 
> Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>

 Applied to master, thanks.

 The rest of the series should go to next, actually. In fact, I should also have
applied flare-engine to next :-(

 Regards,
 Arnout


> ---
>  package/brotli/brotli.mk | 4 ++++
>  1 file changed, 4 insertions(+)
> 
> diff --git a/package/brotli/brotli.mk b/package/brotli/brotli.mk
> index 2c1ad48753..248bfb9daf 100644
> --- a/package/brotli/brotli.mk
> +++ b/package/brotli/brotli.mk
> @@ -14,4 +14,8 @@ BROTLI_CONF_OPTS = \
>  	-DBROTLI_DISABLE_TESTS=ON \
>  	-DBROTLI_BUNDLED_MODE=OFF
>  
> +ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_68485),y)
> +BROTLI_CONF_OPTS += -DCMAKE_C_FLAGS="-O0"
> +endif
> +
>  $(eval $(cmake-package))
>
Giulio Benetti May 27, 2019, 10:17 p.m. UTC | #2
Il 28/05/2019 00:11, Arnout Vandecappelle ha scritto:
> 
> 
> On 27/05/2019 23:38, Giulio Benetti wrote:
>> With Microblaze Gcc version <= 9.x the build fails due to gcc bug 68485:
>> https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68485. The bug show up when
>> building brotli with optimization but not when building with -O0. To
>> work aroung this, if BR2_TOOLCHAIN_HAS_GCC_BUG_68458=y, we force using
>> -O0.
>>
>> Fixes:
>>
>>    http://autobuild.buildroot.net/results/d86/d86251974a0a348a64d9a1d1fd7d02dd4aff0792/
>>
>> Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
> 
>   Applied to master, thanks.
> 
>   The rest of the series should go to next, actually. In fact, I should also have
> applied flare-engine to next :-(

Sure, no problem, I have lot of other Microblaze patches.
Tomorrow I will give priority to bug fix patches and only after to 
"clean-up" patches.

Kind regards
Giulio Benetti May 27, 2019, 10:19 p.m. UTC | #3
Arnout,

Il 28/05/2019 00:17, Giulio Benetti ha scritto:
> Il 28/05/2019 00:11, Arnout Vandecappelle ha scritto:
>>
>>
>> On 27/05/2019 23:38, Giulio Benetti wrote:
>>> With Microblaze Gcc version <= 9.x the build fails due to gcc bug 68485:
>>> https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68485. The bug show up when
>>> building brotli with optimization but not when building with -O0. To
>>> work aroung this, if BR2_TOOLCHAIN_HAS_GCC_BUG_68458=y, we force using
>>> -O0.
>>>
>>> Fixes:
>>>
>>>     http://autobuild.buildroot.net/results/d86/d86251974a0a348a64d9a1d1fd7d02dd4aff0792/
>>>
>>> Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
>>
>>    Applied to master, thanks.
>>
>>    The rest of the series should go to next, actually. In fact, I should also have
>> applied flare-engine to next :-(

Need also this patch, otherwise build is broken:
https://patchwork.ozlabs.org/patch/1105947/

I've forgot to resend it!
diff mbox series

Patch

diff --git a/package/brotli/brotli.mk b/package/brotli/brotli.mk
index 2c1ad48753..248bfb9daf 100644
--- a/package/brotli/brotli.mk
+++ b/package/brotli/brotli.mk
@@ -14,4 +14,8 @@  BROTLI_CONF_OPTS = \
 	-DBROTLI_DISABLE_TESTS=ON \
 	-DBROTLI_BUNDLED_MODE=OFF
 
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_68485),y)
+BROTLI_CONF_OPTS += -DCMAKE_C_FLAGS="-O0"
+endif
+
 $(eval $(cmake-package))