diff mbox series

[1/1] package/bind: drop unneeded static openssl workarounds

Message ID 20190413150453.30125-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/bind: drop unneeded static openssl workarounds | expand

Commit Message

Fabrice Fontaine April 13, 2019, 3:04 p.m. UTC
bind can't be built statically since commit
6045904752b06a8b8e52ba8fc2e49a8548964e8d

So drop uneeded LIBS="-lz" which was added by commit
80ebf12906afc3a1e5f4e5682d4c5dc0779a556a to fix static build with
openssl

Also, drop ac_cv_func_EVP_{sha256,sha384,sha512} that was also added to
fix tests in static build by commit
26aefa672c96caefc17adf59a9ab3d327114ad36

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/bind/bind.mk | 6 +-----
 1 file changed, 1 insertion(+), 5 deletions(-)

Comments

Thomas Petazzoni April 13, 2019, 7:16 p.m. UTC | #1
On Sat, 13 Apr 2019 17:04:53 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> bind can't be built statically since commit
> 6045904752b06a8b8e52ba8fc2e49a8548964e8d
> 
> So drop uneeded LIBS="-lz" which was added by commit
> 80ebf12906afc3a1e5f4e5682d4c5dc0779a556a to fix static build with
> openssl
> 
> Also, drop ac_cv_func_EVP_{sha256,sha384,sha512} that was also added to
> fix tests in static build by commit
> 26aefa672c96caefc17adf59a9ab3d327114ad36
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/bind/bind.mk | 6 +-----
>  1 file changed, 1 insertion(+), 5 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/bind/bind.mk b/package/bind/bind.mk
index 572eacd11a..b2bbafab20 100644
--- a/package/bind/bind.mk
+++ b/package/bind/bind.mk
@@ -55,12 +55,8 @@  endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 BIND_DEPENDENCIES += openssl
-BIND_CONF_ENV += \
-	ac_cv_func_EVP_sha256=yes \
-	ac_cv_func_EVP_sha384=yes \
-	ac_cv_func_EVP_sha512=yes
 BIND_CONF_OPTS += \
-	--with-openssl=$(STAGING_DIR)/usr LIBS="-lz" \
+	--with-openssl=$(STAGING_DIR)/usr \
 	--with-ecdsa=yes \
 	--with-eddsa=no \
 	--with-aes=yes