diff mbox series

[4/6] package/lldpd: add optional libxml2 dependency

Message ID 20190407195833.9275-4-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/6] package/lldpd: update license file | expand

Commit Message

Fabrice Fontaine April 7, 2019, 7:58 p.m. UTC
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/lldpd/lldpd.mk | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/package/lldpd/lldpd.mk b/package/lldpd/lldpd.mk
index 4e62f56c5d..050f45491e 100644
--- a/package/lldpd/lldpd.mk
+++ b/package/lldpd/lldpd.mk
@@ -29,7 +29,6 @@  LLDPD_CONF_ENV = ac_cv_prog_cc_c99=-std=gnu99
 
 LLDPD_CONF_OPTS = \
 	--without-embedded-libevent \
-	--without-xml \
 	--without-seccomp \
 	--without-libbsd \
 	--disable-hardening \
@@ -43,6 +42,13 @@  LLDPD_CONF_OPTS = \
 	$(if $(BR2_PACKAGE_LLDPD_DOT3),--enable-dot3,--disable-dot3) \
 	$(if $(BR2_PACKAGE_LLDPD_CUSTOM_TLV),--enable-custom,--disable-custom)
 
+ifeq ($(BR2_PACKAGE_LIBXML2),y)
+LLDPD_CONF_OPTS += --with-xml
+LLDPD_DEPENDENCIES += libxml2
+else
+LLDPD_CONF_OPTS += --without-xml
+endif
+
 ifeq ($(BR2_PACKAGE_NETSNMP),y)
 LLDPD_CONF_OPTS += --with-snmp
 LLDPD_DEPENDENCIES += netsnmp