diff mbox series

[1/1] package/civetweb: fix static build with openssl

Message ID 20190407163231.20134-1-fontaine.fabrice@gmail.com
State Not Applicable
Headers show
Series [1/1] package/civetweb: fix static build with openssl | expand

Commit Message

Fabrice Fontaine April 7, 2019, 4:32 p.m. UTC
Use pkg-config to retrieve openssl dependencies such as atomic

Fixes:
 - http://autobuild.buildroot.org/results/b2e210bdefe84f4ec9cfda79a33d81788fb7e66c

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/civetweb/civetweb.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni April 10, 2019, 5:11 p.m. UTC | #1
On Sun,  7 Apr 2019 18:32:31 +0200
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Use pkg-config to retrieve openssl dependencies such as atomic
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/b2e210bdefe84f4ec9cfda79a33d81788fb7e66c
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/civetweb/civetweb.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Gaah, sorry, I'm only seeing this patch now, and in the mean time, I
have merged a similar patch from Giulio. Sorry about that :-/

Thomas
Giulio Benetti April 10, 2019, 5:21 p.m. UTC | #2
Il 10/04/2019 19:11, Thomas Petazzoni ha scritto:
> On Sun,  7 Apr 2019 18:32:31 +0200
> Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:
> 
>> Use pkg-config to retrieve openssl dependencies such as atomic
>>
>> Fixes:
>>   - http://autobuild.buildroot.org/results/b2e210bdefe84f4ec9cfda79a33d81788fb7e66c
>>
>> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
>> ---
>>   package/civetweb/civetweb.mk | 4 ++--
>>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> Gaah, sorry, I'm only seeing this patch now, and in the mean time, I
> have merged a similar patch from Giulio. Sorry about that :-/

I was sure to have checked patchwork before submitting.
I'm sorry too Fabrice.
Fabrice Fontaine April 10, 2019, 5:31 p.m. UTC | #3
Hello Giulio and Thomas,

Le mer. 10 avr. 2019 à 19:21, Giulio Benetti
<giulio.benetti@micronovasrl.com> a écrit :
>
> Il 10/04/2019 19:11, Thomas Petazzoni ha scritto:
> > On Sun,  7 Apr 2019 18:32:31 +0200
> > Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:
> >
> >> Use pkg-config to retrieve openssl dependencies such as atomic
> >>
> >> Fixes:
> >>   - http://autobuild.buildroot.org/results/b2e210bdefe84f4ec9cfda79a33d81788fb7e66c
> >>
> >> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> >> ---
> >>   package/civetweb/civetweb.mk | 4 ++--
> >>   1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > Gaah, sorry, I'm only seeing this patch now, and in the mean time, I
> > have merged a similar patch from Giulio. Sorry about that :-/
>
> I was sure to have checked patchwork before submitting.
> I'm sorry too Fabrice.
It's ok :-)
>
> --
> Giulio Benetti
> CTO
>
> MICRONOVA SRL
> Sede: Via A. Niedda 3 - 35010 Vigonza (PD)
> Tel. 049/8931563 - Fax 049/8931346
> Cod.Fiscale - P.IVA 02663420285
> Capitale Sociale € 26.000 i.v.
> Iscritta al Reg. Imprese di Padova N. 02663420285
> Numero R.E.A. 258642
Best Regards,

Fabrice
diff mbox series

Patch

diff --git a/package/civetweb/civetweb.mk b/package/civetweb/civetweb.mk
index fe1cdd5675..94e8f10e26 100644
--- a/package/civetweb/civetweb.mk
+++ b/package/civetweb/civetweb.mk
@@ -32,8 +32,8 @@  endif
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 CIVETWEB_COPT += -DNO_SSL_DL
-CIVETWEB_LIBS += -lssl -lcrypto -lz
-CIVETWEB_DEPENDENCIES += openssl
+CIVETWEB_LIBS += `$(PKG_CONFIG_HOST_BINARY) --libs libssl libcrypto`
+CIVETWEB_DEPENDENCIES += host-pkgconf openssl
 else
 CIVETWEB_COPT += -DNO_SSL
 endif