diff mbox series

[v2,1/4] toolchain-external: introduce BR2_TOOLCHAIN_HAS_OPENMP

Message ID 20190326123032.9905-2-ed.blake@sondrel.com
State Accepted
Headers show
Series toolchain-external: add OpenMP support | expand

Commit Message

Ed Blake March 26, 2019, 12:30 p.m. UTC
Add new BR2_TOOLCHAIN_HAS_OPENMP option for toolchains with OpenMP
support.

Signed-off-by: Ed Blake <ed.blake@sondrel.com>
---
 toolchain/Config.in                                    | 3 +++
 toolchain/toolchain-external/pkg-toolchain-external.mk | 4 ++++
 2 files changed, 7 insertions(+)
diff mbox series

Patch

diff --git a/toolchain/Config.in b/toolchain/Config.in
index bcbc3cf984..bf42e92e00 100644
--- a/toolchain/Config.in
+++ b/toolchain/Config.in
@@ -168,6 +168,9 @@  config BR2_TOOLCHAIN_HAS_SSP
 config BR2_TOOLCHAIN_HAS_UCONTEXT
 	bool
 
+config BR2_TOOLCHAIN_HAS_OPENMP
+	bool
+
 config BR2_TOOLCHAIN_SUPPORTS_PIE
 	bool
 
diff --git a/toolchain/toolchain-external/pkg-toolchain-external.mk b/toolchain/toolchain-external/pkg-toolchain-external.mk
index db3570d96f..747837fdc6 100644
--- a/toolchain/toolchain-external/pkg-toolchain-external.mk
+++ b/toolchain/toolchain-external/pkg-toolchain-external.mk
@@ -144,6 +144,10 @@  TOOLCHAIN_EXTERNAL_LIBS += libquadmath.so*
 endif
 endif
 
+ifeq ($(BR2_TOOLCHAIN_HAS_OPENMP),y)
+TOOLCHAIN_EXTERNAL_LIBS += libgomp.so.*
+endif
+
 TOOLCHAIN_EXTERNAL_LIBS += $(call qstrip,$(BR2_TOOLCHAIN_EXTRA_EXTERNAL_LIBS))