diff mbox series

[1/1] package/gdb: disable inprocess-agent in static build

Message ID 20190222095044.32559-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] package/gdb: disable inprocess-agent in static build | expand

Commit Message

Fabrice Fontaine Feb. 22, 2019, 9:50 a.m. UTC
Fixes:
 - http://autobuild.buildroot.org/results/b40bdbca6669a81301fca523e982dbc9584a4e65

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/gdb/gdb.mk | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Thomas Petazzoni Feb. 22, 2019, 9:28 p.m. UTC | #1
On Fri, 22 Feb 2019 10:50:44 +0100
Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:

> Fixes:
>  - http://autobuild.buildroot.org/results/b40bdbca6669a81301fca523e982dbc9584a4e65
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/gdb/gdb.mk | 5 +++++
>  1 file changed, 5 insertions(+)

Applied to next, thanks.

Thomas
Thomas Petazzoni Feb. 22, 2019, 9:29 p.m. UTC | #2
On Fri, 22 Feb 2019 22:28:40 +0100
Thomas Petazzoni <thomas.petazzoni@bootlin.com> wrote:

> On Fri, 22 Feb 2019 10:50:44 +0100
> Fabrice Fontaine <fontaine.fabrice@gmail.com> wrote:
> 
> > Fixes:
> >  - http://autobuild.buildroot.org/results/b40bdbca6669a81301fca523e982dbc9584a4e65
> > 
> > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> > ---
> >  package/gdb/gdb.mk | 5 +++++
> >  1 file changed, 5 insertions(+)  
> 
> Applied to next, thanks.

Sorry: I applied to master.

Best regards,

Thomas
Peter Korsgaard March 13, 2019, 4:51 p.m. UTC | #3
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Fixes:
 >  - http://autobuild.buildroot.org/results/b40bdbca6669a81301fca523e982dbc9584a4e65

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2018.02.x and 2018.11.x, thanks.
diff mbox series

Patch

diff --git a/package/gdb/gdb.mk b/package/gdb/gdb.mk
index 062f3a730c..a926961372 100644
--- a/package/gdb/gdb.mk
+++ b/package/gdb/gdb.mk
@@ -139,6 +139,11 @@  ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
 GDB_CONF_OPTS += --disable-build-with-cxx
 endif
 
+# inprocess-agent can't be built statically
+ifeq ($(BR2_STATIC_LIBS),y)
+GDB_CONF_OPTS += --disable-inprocess-agent
+endif
+
 ifeq ($(BR2_PACKAGE_GDB_TUI),y)
 GDB_CONF_OPTS += --enable-tui
 else