diff mbox series

[RFC,2/3] wpebackend-fdo: new package

Message ID 20181223154845.23556-3-francois.perrad@gadz.org
State Superseded
Headers show
Series WPE WebKit | expand

Commit Message

Francois Perrad Dec. 23, 2018, 3:48 p.m. UTC
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
---
 DEVELOPERS                                 |  1 +
 package/Config.in                          |  1 +
 package/wpebackend-fdo/Config.in           | 17 +++++++++++++++++
 package/wpebackend-fdo/wpebackend-fdo.hash |  7 +++++++
 package/wpebackend-fdo/wpebackend-fdo.mk   | 15 +++++++++++++++
 5 files changed, 41 insertions(+)
 create mode 100644 package/wpebackend-fdo/Config.in
 create mode 100644 package/wpebackend-fdo/wpebackend-fdo.hash
 create mode 100644 package/wpebackend-fdo/wpebackend-fdo.mk

Comments

Adrian Perez de Castro Dec. 28, 2018, 12:58 a.m. UTC | #1
Hello,

Quick review here...

On Sun, 23 Dec 2018 16:48:44 +0100, Francois Perrad <fperrad@gmail.com> wrote:

> Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> ---
>  DEVELOPERS                                 |  1 +
>  package/Config.in                          |  1 +
>  package/wpebackend-fdo/Config.in           | 17 +++++++++++++++++
>  package/wpebackend-fdo/wpebackend-fdo.hash |  7 +++++++
>  package/wpebackend-fdo/wpebackend-fdo.mk   | 15 +++++++++++++++
>  5 files changed, 41 insertions(+)
>  create mode 100644 package/wpebackend-fdo/Config.in
>  create mode 100644 package/wpebackend-fdo/wpebackend-fdo.hash
>  create mode 100644 package/wpebackend-fdo/wpebackend-fdo.mk
> 
> diff --git a/DEVELOPERS b/DEVELOPERS
> index 705842310..93a2bf5ad 100644
> --- a/DEVELOPERS
> +++ b/DEVELOPERS
> @@ -828,6 +828,7 @@ F:	package/qemu/
>  F:	package/sdl2_mixer/
>  F:	package/sdl2_net/
>  F:	package/tekui/
> +F:	package/wpebackend-fdo/
>  F:	package/wsapi-fcgi/
>  F:	package/wsapi-xavante/
>  F:	utils/scancpan
> diff --git a/package/Config.in b/package/Config.in
> index 7615c5853..e8a676ab0 100644
> --- a/package/Config.in
> +++ b/package/Config.in
> @@ -1302,6 +1302,7 @@ menu "Graphics"
>  	source "package/webkitgtk/Config.in"
>  	source "package/webp/Config.in"
>  	source "package/woff2/Config.in"
> +	source "package/wpebackend-fdo/Config.in"
>  	source "package/zbar/Config.in"
>  	source "package/zxing-cpp/Config.in"
>  endmenu
> diff --git a/package/wpebackend-fdo/Config.in b/package/wpebackend-fdo/Config.in
> new file mode 100644
> index 000000000..9025834e1
> --- /dev/null
> +++ b/package/wpebackend-fdo/Config.in
> @@ -0,0 +1,17 @@
> +comment "wpebackend-fdo needs an OpenEGL-capable backend"
> +	depends on !BR2_PACKAGE_HAS_LIBEGL
> +

The dependency line for the comment needs to be updated to be the reverse
of the list of dependencies for the BR2_PACKAGE_WPEBACKEND_FDO symbol below.

Also, the comment text should follow the Buildroot style:

    foo needs a toolchain w/ featA, featB, featC

(There's more details about this in the Buildroot manual, which you can find
at https://buildroot.org/downloads/manual/manual.html)

> +config BR2_PACKAGE_WPEBACKEND_FDO
> +	bool "wpebackend-fdo"
> +	depends on !BR2_STATIC_LIBS # dlfcn.h
> +	depends on BR2_TOOLCHAIN_HAS_THREADS # wayland
> +	depends on BR2_USE_WCHAR # gettext
> +	depends on BR2_USE_MMU # fork()

The BR2_USE_MMU belongs in the “wpewebkit” package (the backend itself does
no forking), and should not be needed here.

The BR2_USE_WCHAR dependency should not be needed here, as gettext is not
required nor used by this package, neither it is needed by “wayland” nor
“libxkbcommon”.

> +	depends on BR2_PACKAGE_HAS_LIBEGL
> +	select BR2_PACKAGE_LIBGLIB2
> +	select BR2_PACKAGE_LIBWPE
> +	select BR2_PACKAGE_WAYLAND
> +	help
> +	  WPE's backend based on a freedesktop.org stack.
> +
> +	  https://wpewebkit.org/
> diff --git a/package/wpebackend-fdo/wpebackend-fdo.hash b/package/wpebackend-fdo/wpebackend-fdo.hash
> new file mode 100644
> index 000000000..6ebfcf335
> --- /dev/null
> +++ b/package/wpebackend-fdo/wpebackend-fdo.hash
> @@ -0,0 +1,7 @@
> +# From https://wpewebkit.org/releases/wpebackend-fdo-1.1.0.tar.xz.sums
> +md5 dc852a6cafaf4b6392dcb91e36cd7abb wpebackend-fdo-1.1.0.tar.xz
> +sha1 688377f441e19273fe2b44c0a2ea9da149f97fa4 wpebackend-fdo-1.1.0.tar.xz
> +sha256 f6c72130d16e50860cb83eb0f6e109c76f1826d2c6bee39025fb3651941761e7 wpebackend-fdo-1.1.0.tar.xz
> +
> +# Hashes for license files:
> +sha256 c9f6803371047fad3e72200ec6cd226329a5ee08ac61104c8211c2761fb46825 COPYING
> diff --git a/package/wpebackend-fdo/wpebackend-fdo.mk b/package/wpebackend-fdo/wpebackend-fdo.mk
> new file mode 100644
> index 000000000..b62e710a9
> --- /dev/null
> +++ b/package/wpebackend-fdo/wpebackend-fdo.mk
> @@ -0,0 +1,15 @@
> +################################################################################
> +#
> +# wpebackend-fdo
> +#
> +################################################################################
> +
> +WPEBACKEND_FDO_VERSION = 1.1.0

As with libwpe, please use version 1.0.0 here.

> +WPEBACKEND_FDO_SITE = http://wpewebkit.org/releases
> +WPEBACKEND_FDO_SOURCE = wpebackend-fdo-$(WPEBACKEND_FDO_VERSION).tar.xz
> +WPEBACKEND_FDO_INSTALL_STAGING = YES
> +WPEBACKEND_FDO_LICENSE = BSD-2-Clause
> +WPEBACKEND_FDO_LICENSE_FILES = COPYING
> +WPEBACKEND_FDO_DEPENDENCIES = libglib2 libwpe wayland

This is missing “libegl” here.

> +$(eval $(cmake-package))
> -- 
> 2.17.1


-Adrián
Francois Perrad Dec. 29, 2018, 9:15 a.m. UTC | #2
Le ven. 28 déc. 2018 à 01:58, Adrian Perez de Castro <aperez@igalia.com> a
écrit :

> Hello,
>
> Quick review here...
>
> On Sun, 23 Dec 2018 16:48:44 +0100, Francois Perrad <fperrad@gmail.com>
> wrote:
>
> > Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
> > ---
> >  DEVELOPERS                                 |  1 +
> >  package/Config.in                          |  1 +
> >  package/wpebackend-fdo/Config.in           | 17 +++++++++++++++++
> >  package/wpebackend-fdo/wpebackend-fdo.hash |  7 +++++++
> >  package/wpebackend-fdo/wpebackend-fdo.mk   | 15 +++++++++++++++
> >  5 files changed, 41 insertions(+)
> >  create mode 100644 package/wpebackend-fdo/Config.in
> >  create mode 100644 package/wpebackend-fdo/wpebackend-fdo.hash
> >  create mode 100644 package/wpebackend-fdo/wpebackend-fdo.mk
> >
> > diff --git a/DEVELOPERS b/DEVELOPERS
> > index 705842310..93a2bf5ad 100644
> > --- a/DEVELOPERS
> > +++ b/DEVELOPERS
> > @@ -828,6 +828,7 @@ F:        package/qemu/
> >  F:   package/sdl2_mixer/
> >  F:   package/sdl2_net/
> >  F:   package/tekui/
> > +F:   package/wpebackend-fdo/
> >  F:   package/wsapi-fcgi/
> >  F:   package/wsapi-xavante/
> >  F:   utils/scancpan
> > diff --git a/package/Config.in b/package/Config.in
> > index 7615c5853..e8a676ab0 100644
> > --- a/package/Config.in
> > +++ b/package/Config.in
> > @@ -1302,6 +1302,7 @@ menu "Graphics"
> >       source "package/webkitgtk/Config.in"
> >       source "package/webp/Config.in"
> >       source "package/woff2/Config.in"
> > +     source "package/wpebackend-fdo/Config.in"
> >       source "package/zbar/Config.in"
> >       source "package/zxing-cpp/Config.in"
> >  endmenu
> > diff --git a/package/wpebackend-fdo/Config.in
> b/package/wpebackend-fdo/Config.in
> > new file mode 100644
> > index 000000000..9025834e1
> > --- /dev/null
> > +++ b/package/wpebackend-fdo/Config.in
> > @@ -0,0 +1,17 @@
> > +comment "wpebackend-fdo needs an OpenEGL-capable backend"
> > +     depends on !BR2_PACKAGE_HAS_LIBEGL
> > +
>
> The dependency line for the comment needs to be updated to be the reverse
> of the list of dependencies for the BR2_PACKAGE_WPEBACKEND_FDO symbol
> below.
>
> Also, the comment text should follow the Buildroot style:
>
>     foo needs a toolchain w/ featA, featB, featC
>
> (There's more details about this in the Buildroot manual, which you can
> find
> at https://buildroot.org/downloads/manual/manual.html)
>
> > +config BR2_PACKAGE_WPEBACKEND_FDO
> > +     bool "wpebackend-fdo"
> > +     depends on !BR2_STATIC_LIBS # dlfcn.h
> > +     depends on BR2_TOOLCHAIN_HAS_THREADS # wayland
> > +     depends on BR2_USE_WCHAR # gettext
> > +     depends on BR2_USE_MMU # fork()
>
> The BR2_USE_MMU belongs in the “wpewebkit” package (the backend itself does
> no forking), and should not be needed here.
>
> The BR2_USE_WCHAR dependency should not be needed here, as gettext is not
> required nor used by this package, neither it is needed by “wayland” nor
> “libxkbcommon”.
>
>
These two dependencies comes from LIBGLIB2

> +     depends on BR2_PACKAGE_HAS_LIBEGL
> > +     select BR2_PACKAGE_LIBGLIB2
> > +     select BR2_PACKAGE_LIBWPE
> > +     select BR2_PACKAGE_WAYLAND
> > +     help
> > +       WPE's backend based on a freedesktop.org stack.
> > +
> > +       https://wpewebkit.org/
> > diff --git a/package/wpebackend-fdo/wpebackend-fdo.hash
> b/package/wpebackend-fdo/wpebackend-fdo.hash
> > new file mode 100644
> > index 000000000..6ebfcf335
> > --- /dev/null
> > +++ b/package/wpebackend-fdo/wpebackend-fdo.hash
> > @@ -0,0 +1,7 @@
> > +# From https://wpewebkit.org/releases/wpebackend-fdo-1.1.0.tar.xz.sums
> > +md5 dc852a6cafaf4b6392dcb91e36cd7abb wpebackend-fdo-1.1.0.tar.xz
> > +sha1 688377f441e19273fe2b44c0a2ea9da149f97fa4
> wpebackend-fdo-1.1.0.tar.xz
> > +sha256 f6c72130d16e50860cb83eb0f6e109c76f1826d2c6bee39025fb3651941761e7
> wpebackend-fdo-1.1.0.tar.xz
> > +
> > +# Hashes for license files:
> > +sha256 c9f6803371047fad3e72200ec6cd226329a5ee08ac61104c8211c2761fb46825
> COPYING
> > diff --git a/package/wpebackend-fdo/wpebackend-fdo.mk
> b/package/wpebackend-fdo/wpebackend-fdo.mk
> > new file mode 100644
> > index 000000000..b62e710a9
> > --- /dev/null
> > +++ b/package/wpebackend-fdo/wpebackend-fdo.mk
> > @@ -0,0 +1,15 @@
> >
> +################################################################################
> > +#
> > +# wpebackend-fdo
> > +#
> >
> +################################################################################
> > +
> > +WPEBACKEND_FDO_VERSION = 1.1.0
>
> As with libwpe, please use version 1.0.0 here.
>
> > +WPEBACKEND_FDO_SITE = http://wpewebkit.org/releases
> > +WPEBACKEND_FDO_SOURCE = wpebackend-fdo-$(WPEBACKEND_FDO_VERSION).tar.xz
> > +WPEBACKEND_FDO_INSTALL_STAGING = YES
> > +WPEBACKEND_FDO_LICENSE = BSD-2-Clause
> > +WPEBACKEND_FDO_LICENSE_FILES = COPYING
> > +WPEBACKEND_FDO_DEPENDENCIES = libglib2 libwpe wayland
>
> This is missing “libegl” here.
>
>
libegl is not needed here, libegl is already a dependency of libwpe.

François

> +$(eval $(cmake-package))
> > --
> > 2.17.1
>
>
> -Adrián
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
>
<div dir="ltr"><div dir="ltr"><br></div><br><div class="gmail_quote"><div dir="ltr">Le ven. 28 déc. 2018 à 01:58, Adrian Perez de Castro &lt;<a href="mailto:aperez@igalia.com">aperez@igalia.com</a>&gt; a écrit :<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Hello,<br>
<br>
Quick review here...<br>
<br>
On Sun, 23 Dec 2018 16:48:44 +0100, Francois Perrad &lt;<a href="mailto:fperrad@gmail.com" target="_blank">fperrad@gmail.com</a>&gt; wrote:<br>
<br>
&gt; Signed-off-by: Francois Perrad &lt;<a href="mailto:francois.perrad@gadz.org" target="_blank">francois.perrad@gadz.org</a>&gt;<br>
&gt; ---<br>
&gt;  DEVELOPERS                                 |  1 +<br>
&gt;  package/Config.in                          |  1 +<br>
&gt;  package/wpebackend-fdo/Config.in           | 17 +++++++++++++++++<br>
&gt;  package/wpebackend-fdo/wpebackend-fdo.hash |  7 +++++++<br>
&gt;  package/wpebackend-fdo/<a href="http://wpebackend-fdo.mk" rel="noreferrer" target="_blank">wpebackend-fdo.mk</a>   | 15 +++++++++++++++<br>
&gt;  5 files changed, 41 insertions(+)<br>
&gt;  create mode 100644 package/wpebackend-fdo/Config.in<br>
&gt;  create mode 100644 package/wpebackend-fdo/wpebackend-fdo.hash<br>
&gt;  create mode 100644 package/wpebackend-fdo/<a href="http://wpebackend-fdo.mk" rel="noreferrer" target="_blank">wpebackend-fdo.mk</a><br>
&gt; <br>
&gt; diff --git a/DEVELOPERS b/DEVELOPERS<br>
&gt; index 705842310..93a2bf5ad 100644<br>
&gt; --- a/DEVELOPERS<br>
&gt; +++ b/DEVELOPERS<br>
&gt; @@ -828,6 +828,7 @@ F:        package/qemu/<br>
&gt;  F:   package/sdl2_mixer/<br>
&gt;  F:   package/sdl2_net/<br>
&gt;  F:   package/tekui/<br>
&gt; +F:   package/wpebackend-fdo/<br>
&gt;  F:   package/wsapi-fcgi/<br>
&gt;  F:   package/wsapi-xavante/<br>
&gt;  F:   utils/scancpan<br>
&gt; diff --git a/package/Config.in b/package/Config.in<br>
&gt; index 7615c5853..e8a676ab0 100644<br>
&gt; --- a/package/Config.in<br>
&gt; +++ b/package/Config.in<br>
&gt; @@ -1302,6 +1302,7 @@ menu &quot;Graphics&quot;<br>
&gt;       source &quot;package/webkitgtk/Config.in&quot;<br>
&gt;       source &quot;package/webp/Config.in&quot;<br>
&gt;       source &quot;package/woff2/Config.in&quot;<br>
&gt; +     source &quot;package/wpebackend-fdo/Config.in&quot;<br>
&gt;       source &quot;package/zbar/Config.in&quot;<br>
&gt;       source &quot;package/zxing-cpp/Config.in&quot;<br>
&gt;  endmenu<br>
&gt; diff --git a/package/wpebackend-fdo/Config.in b/package/wpebackend-fdo/Config.in<br>
&gt; new file mode 100644<br>
&gt; index 000000000..9025834e1<br>
&gt; --- /dev/null<br>
&gt; +++ b/package/wpebackend-fdo/Config.in<br>
&gt; @@ -0,0 +1,17 @@<br>
&gt; +comment &quot;wpebackend-fdo needs an OpenEGL-capable backend&quot;<br>
&gt; +     depends on !BR2_PACKAGE_HAS_LIBEGL<br>
&gt; +<br>
<br>
The dependency line for the comment needs to be updated to be the reverse<br>
of the list of dependencies for the BR2_PACKAGE_WPEBACKEND_FDO symbol below.<br>
<br>
Also, the comment text should follow the Buildroot style:<br>
<br>
    foo needs a toolchain w/ featA, featB, featC<br>
<br>
(There&#39;s more details about this in the Buildroot manual, which you can find<br>
at <a href="https://buildroot.org/downloads/manual/manual.html" rel="noreferrer" target="_blank">https://buildroot.org/downloads/manual/manual.html</a>)<br>
<br>
&gt; +config BR2_PACKAGE_WPEBACKEND_FDO<br>
&gt; +     bool &quot;wpebackend-fdo&quot;<br>
&gt; +     depends on !BR2_STATIC_LIBS # dlfcn.h<br>
&gt; +     depends on BR2_TOOLCHAIN_HAS_THREADS # wayland<br>
&gt; +     depends on BR2_USE_WCHAR # gettext<br>
&gt; +     depends on BR2_USE_MMU # fork()<br>
<br>
The BR2_USE_MMU belongs in the “wpewebkit” package (the backend itself does<br>
no forking), and should not be needed here.<br>
<br>
The BR2_USE_WCHAR dependency should not be needed here, as gettext is not<br>
required nor used by this package, neither it is needed by “wayland” nor<br>
“libxkbcommon”.<br>
<br></blockquote><div><br></div><div>These two dependencies comes from LIBGLIB2<br></div><div><br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
&gt; +     depends on BR2_PACKAGE_HAS_LIBEGL<br>
&gt; +     select BR2_PACKAGE_LIBGLIB2<br>
&gt; +     select BR2_PACKAGE_LIBWPE<br>
&gt; +     select BR2_PACKAGE_WAYLAND<br>
&gt; +     help<br>
&gt; +       WPE&#39;s backend based on a <a href="http://freedesktop.org" rel="noreferrer" target="_blank">freedesktop.org</a> stack.<br>
&gt; +<br>
&gt; +       <a href="https://wpewebkit.org/" rel="noreferrer" target="_blank">https://wpewebkit.org/</a><br>
&gt; diff --git a/package/wpebackend-fdo/wpebackend-fdo.hash b/package/wpebackend-fdo/wpebackend-fdo.hash<br>
&gt; new file mode 100644<br>
&gt; index 000000000..6ebfcf335<br>
&gt; --- /dev/null<br>
&gt; +++ b/package/wpebackend-fdo/wpebackend-fdo.hash<br>
&gt; @@ -0,0 +1,7 @@<br>
&gt; +# From <a href="https://wpewebkit.org/releases/wpebackend-fdo-1.1.0.tar.xz.sums" rel="noreferrer" target="_blank">https://wpewebkit.org/releases/wpebackend-fdo-1.1.0.tar.xz.sums</a><br>
&gt; +md5 dc852a6cafaf4b6392dcb91e36cd7abb wpebackend-fdo-1.1.0.tar.xz<br>
&gt; +sha1 688377f441e19273fe2b44c0a2ea9da149f97fa4 wpebackend-fdo-1.1.0.tar.xz<br>
&gt; +sha256 f6c72130d16e50860cb83eb0f6e109c76f1826d2c6bee39025fb3651941761e7 wpebackend-fdo-1.1.0.tar.xz<br>
&gt; +<br>
&gt; +# Hashes for license files:<br>
&gt; +sha256 c9f6803371047fad3e72200ec6cd226329a5ee08ac61104c8211c2761fb46825 COPYING<br>
&gt; diff --git a/package/wpebackend-fdo/<a href="http://wpebackend-fdo.mk" rel="noreferrer" target="_blank">wpebackend-fdo.mk</a> b/package/wpebackend-fdo/<a href="http://wpebackend-fdo.mk" rel="noreferrer" target="_blank">wpebackend-fdo.mk</a><br>
&gt; new file mode 100644<br>
&gt; index 000000000..b62e710a9<br>
&gt; --- /dev/null<br>
&gt; +++ b/package/wpebackend-fdo/<a href="http://wpebackend-fdo.mk" rel="noreferrer" target="_blank">wpebackend-fdo.mk</a><br>
&gt; @@ -0,0 +1,15 @@<br>
&gt; +################################################################################<br>
&gt; +#<br>
&gt; +# wpebackend-fdo<br>
&gt; +#<br>
&gt; +################################################################################<br>
&gt; +<br>
&gt; +WPEBACKEND_FDO_VERSION = 1.1.0<br>
<br>
As with libwpe, please use version 1.0.0 here.<br>
<br>
&gt; +WPEBACKEND_FDO_SITE = <a href="http://wpewebkit.org/releases" rel="noreferrer" target="_blank">http://wpewebkit.org/releases</a><br>
&gt; +WPEBACKEND_FDO_SOURCE = wpebackend-fdo-$(WPEBACKEND_FDO_VERSION).tar.xz<br>
&gt; +WPEBACKEND_FDO_INSTALL_STAGING = YES<br>
&gt; +WPEBACKEND_FDO_LICENSE = BSD-2-Clause<br>
&gt; +WPEBACKEND_FDO_LICENSE_FILES = COPYING<br>
&gt; +WPEBACKEND_FDO_DEPENDENCIES = libglib2 libwpe wayland<br>
<br>
This is missing “libegl” here.<br>
<br></blockquote><div><br></div><div>libegl is not needed here, libegl is already a dependency of libwpe.</div><div><br></div><div>François<br></div><div> <br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
&gt; +$(eval $(cmake-package))<br>
&gt; -- <br>
&gt; 2.17.1<br>
<br>
<br>
-Adrián<br>
_______________________________________________<br>
buildroot mailing list<br>
<a href="mailto:buildroot@busybox.net" target="_blank">buildroot@busybox.net</a><br>
<a href="http://lists.busybox.net/mailman/listinfo/buildroot" rel="noreferrer" target="_blank">http://lists.busybox.net/mailman/listinfo/buildroot</a><br>
</blockquote></div></div>
Thomas Petazzoni Dec. 31, 2018, 2:02 p.m. UTC | #3
Hello Adrian,

Thanks for the review!

On Fri, 28 Dec 2018 01:58:02 +0100, Adrian Perez de Castro wrote:

> > diff --git a/package/wpebackend-fdo/Config.in b/package/wpebackend-fdo/Config.in
> > new file mode 100644
> > index 000000000..9025834e1
> > --- /dev/null
> > +++ b/package/wpebackend-fdo/Config.in
> > @@ -0,0 +1,17 @@
> > +comment "wpebackend-fdo needs an OpenEGL-capable backend"
> > +	depends on !BR2_PACKAGE_HAS_LIBEGL
> > +  
> 
> The dependency line for the comment needs to be updated to be the reverse
> of the list of dependencies for the BR2_PACKAGE_WPEBACKEND_FDO symbol below.
> 
> Also, the comment text should follow the Buildroot style:
> 
>     foo needs a toolchain w/ featA, featB, featC

Actually this form applies to toolchain features. For something like
OpenGL, we do use a comment similar to what François has used. See:

$ git grep "comment.*OpenGL"

Thanks,

Thomas
diff mbox series

Patch

diff --git a/DEVELOPERS b/DEVELOPERS
index 705842310..93a2bf5ad 100644
--- a/DEVELOPERS
+++ b/DEVELOPERS
@@ -828,6 +828,7 @@  F:	package/qemu/
 F:	package/sdl2_mixer/
 F:	package/sdl2_net/
 F:	package/tekui/
+F:	package/wpebackend-fdo/
 F:	package/wsapi-fcgi/
 F:	package/wsapi-xavante/
 F:	utils/scancpan
diff --git a/package/Config.in b/package/Config.in
index 7615c5853..e8a676ab0 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -1302,6 +1302,7 @@  menu "Graphics"
 	source "package/webkitgtk/Config.in"
 	source "package/webp/Config.in"
 	source "package/woff2/Config.in"
+	source "package/wpebackend-fdo/Config.in"
 	source "package/zbar/Config.in"
 	source "package/zxing-cpp/Config.in"
 endmenu
diff --git a/package/wpebackend-fdo/Config.in b/package/wpebackend-fdo/Config.in
new file mode 100644
index 000000000..9025834e1
--- /dev/null
+++ b/package/wpebackend-fdo/Config.in
@@ -0,0 +1,17 @@ 
+comment "wpebackend-fdo needs an OpenEGL-capable backend"
+	depends on !BR2_PACKAGE_HAS_LIBEGL
+
+config BR2_PACKAGE_WPEBACKEND_FDO
+	bool "wpebackend-fdo"
+	depends on !BR2_STATIC_LIBS # dlfcn.h
+	depends on BR2_TOOLCHAIN_HAS_THREADS # wayland
+	depends on BR2_USE_WCHAR # gettext
+	depends on BR2_USE_MMU # fork()
+	depends on BR2_PACKAGE_HAS_LIBEGL
+	select BR2_PACKAGE_LIBGLIB2
+	select BR2_PACKAGE_LIBWPE
+	select BR2_PACKAGE_WAYLAND
+	help
+	  WPE's backend based on a freedesktop.org stack.
+
+	  https://wpewebkit.org/
diff --git a/package/wpebackend-fdo/wpebackend-fdo.hash b/package/wpebackend-fdo/wpebackend-fdo.hash
new file mode 100644
index 000000000..6ebfcf335
--- /dev/null
+++ b/package/wpebackend-fdo/wpebackend-fdo.hash
@@ -0,0 +1,7 @@ 
+# From https://wpewebkit.org/releases/wpebackend-fdo-1.1.0.tar.xz.sums
+md5 dc852a6cafaf4b6392dcb91e36cd7abb wpebackend-fdo-1.1.0.tar.xz
+sha1 688377f441e19273fe2b44c0a2ea9da149f97fa4 wpebackend-fdo-1.1.0.tar.xz
+sha256 f6c72130d16e50860cb83eb0f6e109c76f1826d2c6bee39025fb3651941761e7 wpebackend-fdo-1.1.0.tar.xz
+
+# Hashes for license files:
+sha256 c9f6803371047fad3e72200ec6cd226329a5ee08ac61104c8211c2761fb46825 COPYING
diff --git a/package/wpebackend-fdo/wpebackend-fdo.mk b/package/wpebackend-fdo/wpebackend-fdo.mk
new file mode 100644
index 000000000..b62e710a9
--- /dev/null
+++ b/package/wpebackend-fdo/wpebackend-fdo.mk
@@ -0,0 +1,15 @@ 
+################################################################################
+#
+# wpebackend-fdo
+#
+################################################################################
+
+WPEBACKEND_FDO_VERSION = 1.1.0
+WPEBACKEND_FDO_SITE = http://wpewebkit.org/releases
+WPEBACKEND_FDO_SOURCE = wpebackend-fdo-$(WPEBACKEND_FDO_VERSION).tar.xz
+WPEBACKEND_FDO_INSTALL_STAGING = YES
+WPEBACKEND_FDO_LICENSE = BSD-2-Clause
+WPEBACKEND_FDO_LICENSE_FILES = COPYING
+WPEBACKEND_FDO_DEPENDENCIES = libglib2 libwpe wayland
+
+$(eval $(cmake-package))