diff mbox series

[1/1] connman: fix systemd build wih pkgconf 1.5.3

Message ID 20181216102909.32124-1-fontaine.fabrice@gmail.com
State Superseded
Headers show
Series [1/1] connman: fix systemd build wih pkgconf 1.5.3 | expand

Commit Message

Fabrice Fontaine Dec. 16, 2018, 10:29 a.m. UTC
Since the bump to 1.5.3, pkgconf prepends the sysroot to all absolute
paths found in the .pc file. This is correct when the paths refer to
something in STAGING_DIR (e.g. libdir, includedir), but not when it
refers to something used for the target.

connman uses the tmpfilesdir variable from systemd.pc to decide where to
install things. Since DESTDIR is prepended to the install destination,
this will end up in the wrong location.

Until a better solution is found in pkgconf, pass the tmpfilesdir to use
explicitly instead of relying on systemd.pc.

Fixes:
 - http://autobuild.buildroot.org/results/6a13e6dfc58b2b3f8fbad6d6d6462370a75a8ad4

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/connman/connman.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Petr Vorel Dec. 19, 2018, 9:15 p.m. UTC | #1
Hi Fabrice,

> Since the bump to 1.5.3, pkgconf prepends the sysroot to all absolute
> paths found in the .pc file. This is correct when the paths refer to
> something in STAGING_DIR (e.g. libdir, includedir), but not when it
> refers to something used for the target.

> connman uses the tmpfilesdir variable from systemd.pc to decide where to
> install things. Since DESTDIR is prepended to the install destination,
> this will end up in the wrong location.

> Until a better solution is found in pkgconf, pass the tmpfilesdir to use
> explicitly instead of relying on systemd.pc.

> Fixes:
>  - http://autobuild.buildroot.org/results/6a13e6dfc58b2b3f8fbad6d6d6462370a75a8ad4

> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Acked-by: Petr Vorel <petr.vorel@gmail.com>

Thanks for your fix!


Kind regards,
Petr
diff mbox series

Patch

diff --git a/package/connman/connman.mk b/package/connman/connman.mk
index b67d1c4b86..ce73c5acc1 100644
--- a/package/connman/connman.mk
+++ b/package/connman/connman.mk
@@ -13,6 +13,7 @@  CONNMAN_LICENSE = GPL-2.0
 CONNMAN_LICENSE_FILES = COPYING
 CONNMAN_CONF_OPTS += \
 	--with-dbusconfdir=/etc \
+	--with-tmpfilesdir=/usr/lib/tmpfiles.d \
 	$(if $(BR2_PACKAGE_CONNMAN_DEBUG),--enable-debug,--disable-debug) \
 	$(if $(BR2_PACKAGE_CONNMAN_ETHERNET),--enable-ethernet,--disable-ethernet) \
 	$(if $(BR2_PACKAGE_CONNMAN_WIFI),--enable-wifi,--disable-wifi) \