diff mbox series

package/sdl2_net: add missing host-pkgconf dependency

Message ID 20181212085212.12149-1-thomas.petazzoni@bootlin.com
State Accepted
Headers show
Series package/sdl2_net: add missing host-pkgconf dependency | expand

Commit Message

Thomas Petazzoni Dec. 12, 2018, 8:52 a.m. UTC
The sdl2_net configure script uses pkg-config to finx sdl2. If it
doesn't find pkg-config, it tries to locate sdl2-config, and defaults
to /usr/bin/sdl2-config, which causes the build to fail with:

arm-linux-gcc: ERROR: unsafe header/library path used in cross-compilation: '-I/usr/include/SDL2'

Fix this by adding host-pkgconf to the dependencies of sdl2_net. We
could have added the right autoconf cache variable to tell the
configure script where sdl2-config is located, but since pkg-config is
tried first, let's use that.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/sdl2_net/sdl2_net.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Dec. 13, 2018, 8:17 p.m. UTC | #1
Hello,

On Wed, 12 Dec 2018 09:52:12 +0100, Thomas Petazzoni wrote:
> The sdl2_net configure script uses pkg-config to finx sdl2. If it
> doesn't find pkg-config, it tries to locate sdl2-config, and defaults
> to /usr/bin/sdl2-config, which causes the build to fail with:
> 
> arm-linux-gcc: ERROR: unsafe header/library path used in cross-compilation: '-I/usr/include/SDL2'
> 
> Fix this by adding host-pkgconf to the dependencies of sdl2_net. We
> could have added the right autoconf cache variable to tell the
> configure script where sdl2-config is located, but since pkg-config is
> tried first, let's use that.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> ---
>  package/sdl2_net/sdl2_net.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Dec. 16, 2018, 9:16 p.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@bootlin.com> writes:

 > The sdl2_net configure script uses pkg-config to finx sdl2. If it
 > doesn't find pkg-config, it tries to locate sdl2-config, and defaults
 > to /usr/bin/sdl2-config, which causes the build to fail with:

 > arm-linux-gcc: ERROR: unsafe header/library path used in cross-compilation: '-I/usr/include/SDL2'

 > Fix this by adding host-pkgconf to the dependencies of sdl2_net. We
 > could have added the right autoconf cache variable to tell the
 > configure script where sdl2-config is located, but since pkg-config is
 > tried first, let's use that.

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Committed to 2018.02.x, 2018.08.x and 2018.11.x, thanks.
diff mbox series

Patch

diff --git a/package/sdl2_net/sdl2_net.mk b/package/sdl2_net/sdl2_net.mk
index 2fa4a8c2e0..93bf3a2eb3 100644
--- a/package/sdl2_net/sdl2_net.mk
+++ b/package/sdl2_net/sdl2_net.mk
@@ -10,6 +10,6 @@  SDL2_NET_SITE = http://www.libsdl.org/projects/SDL_net/release
 SDL2_NET_LICENSE = Zlib
 SDL2_NET_LICENSE_FILES = COPYING.txt
 SDL2_NET_INSTALL_STAGING = YES
-SDL2_NET_DEPENDENCIES = sdl2
+SDL2_NET_DEPENDENCIES = sdl2 host-pkgconf
 
 $(eval $(autotools-package))