diff mbox series

[1/1] libva: fix build with pkgconf 1.5.3

Message ID 20181211181943.14944-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] libva: fix build with pkgconf 1.5.3 | expand

Commit Message

Fabrice Fontaine Dec. 11, 2018, 6:19 p.m. UTC
Set ac_cv_path_WAYLAND_SCANNER to the wayland-scanner in the host
directory otherwise build will fail because libva will use pkgconfig to
find it

Fixes:
 - http://autobuild.buildroot.org/results/836d3a7085c576f607b1532d5204a54d6c2c1e66

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/libva/libva.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Dec. 13, 2018, 8:48 p.m. UTC | #1
Hello,

On Tue, 11 Dec 2018 19:19:43 +0100, Fabrice Fontaine wrote:
> Set ac_cv_path_WAYLAND_SCANNER to the wayland-scanner in the host
> directory otherwise build will fail because libva will use pkgconfig to
> find it
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/836d3a7085c576f607b1532d5204a54d6c2c1e66
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/libva/libva.mk | 1 +
>  1 file changed, 1 insertion(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/libva/libva.mk b/package/libva/libva.mk
index 9a70bb83fd..b897d35849 100644
--- a/package/libva/libva.mk
+++ b/package/libva/libva.mk
@@ -30,6 +30,7 @@  endif
 
 ifeq ($(BR2_PACKAGE_WAYLAND),y)
 LIBVA_DEPENDENCIES += wayland
+LIBVA_CONF_ENV += ac_cv_path_WAYLAND_SCANNER=$(HOST_DIR)/usr/bin/wayland-scanner
 LIBVA_CONF_OPTS += --enable-wayland
 else
 LIBVA_CONF_OPTS += --disable-wayland