diff mbox series

[3/6] gvfs: enable admin backend

Message ID 20181019201315.15922-3-fontaine.fabrice@gmail.com
State Accepted
Commit 1f595f3cf6af9867322b2b631cec3dbda42a43c7
Headers show
Series [1/6] gvfs: add libusb support | expand

Commit Message

Fabrice Fontaine Oct. 19, 2018, 8:13 p.m. UTC
Enable admin backend if libcap and polkit are available

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/gvfs/gvfs.mk | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Oct. 20, 2018, 4:09 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > Enable admin backend if libcap and polkit are available
 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/gvfs/gvfs.mk b/package/gvfs/gvfs.mk
index 82683d7da1..4ad66b8a6a 100644
--- a/package/gvfs/gvfs.mk
+++ b/package/gvfs/gvfs.mk
@@ -20,7 +20,6 @@  GVFS_CONF_ENV = ac_cv_path_LIBGCRYPT_CONFIG=$(STAGING_DIR)/usr/bin/libgcrypt-con
 # Most of these are missing library support
 GVFS_CONF_OPTS = \
 	--disable-afc \
-	--disable-admin \
 	--disable-cdda \
 	--disable-gcr \
 	--disable-gdu \
@@ -66,6 +65,13 @@  else
 GVFS_CONF_OPTS += --disable-bluray
 endif
 
+ifeq ($(BR2_PACKAGE_LIBCAP)$(BR2_PACKAGE_POLKIT),yy)
+GVFS_DEPENDENCIES += libcap polkit
+GVFS_CONF_OPTS += --enable-admin
+else
+GVFS_CONF_OPTS += --disable-admin
+endif
+
 ifeq ($(BR2_PACKAGE_LIBFUSE),y)
 GVFS_DEPENDENCIES += libfuse
 GVFS_CONF_OPTS += --enable-fuse