diff mbox series

[1/1] screen: fix parallel build

Message ID 20181003210624.3085-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] screen: fix parallel build | expand

Commit Message

Fabrice Fontaine Oct. 3, 2018, 9:06 p.m. UTC
comm.h is needed to build list_display.o and list_generic.o otherwise
parallel builds will sometimes fail

Fixes:
 - http://autobuild.buildroot.org/results/43105f14857dbe72d8878fc7b3db67f7bdca93cc
 - http://autobuild.buildroot.org/results/47f4ecbec1355285633df287fc9c4e7cccde9378

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 ...-needed-for-list_-display-generic-.o.patch | 35 +++++++++++++++++++
 1 file changed, 35 insertions(+)
 create mode 100644 package/screen/0011-comm.h-needed-for-list_-display-generic-.o.patch

Comments

Thomas Petazzoni Oct. 4, 2018, 12:36 p.m. UTC | #1
Hello,

On Wed,  3 Oct 2018 23:06:24 +0200, Fabrice Fontaine wrote:
> comm.h is needed to build list_display.o and list_generic.o otherwise
> parallel builds will sometimes fail
> 
> Fixes:
>  - http://autobuild.buildroot.org/results/43105f14857dbe72d8878fc7b3db67f7bdca93cc
>  - http://autobuild.buildroot.org/results/47f4ecbec1355285633df287fc9c4e7cccde9378
> 
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  ...-needed-for-list_-display-generic-.o.patch | 35 +++++++++++++++++++
>  1 file changed, 35 insertions(+)
>  create mode 100644 package/screen/0011-comm.h-needed-for-list_-display-generic-.o.patch

Applied to master, thanks.

Thomas
Peter Korsgaard Oct. 5, 2018, 8:34 p.m. UTC | #2
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > comm.h is needed to build list_display.o and list_generic.o otherwise
 > parallel builds will sometimes fail

 > Fixes:
 >  - http://autobuild.buildroot.org/results/43105f14857dbe72d8878fc7b3db67f7bdca93cc
 >  - http://autobuild.buildroot.org/results/47f4ecbec1355285633df287fc9c4e7cccde9378

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed to 2018.02.x, 2018.05.x and 2018.08.x, thanks.
diff mbox series

Patch

diff --git a/package/screen/0011-comm.h-needed-for-list_-display-generic-.o.patch b/package/screen/0011-comm.h-needed-for-list_-display-generic-.o.patch
new file mode 100644
index 0000000000..f406a1afac
--- /dev/null
+++ b/package/screen/0011-comm.h-needed-for-list_-display-generic-.o.patch
@@ -0,0 +1,35 @@ 
+From b719314d201a3e9e1e57c65746a468c47bfc847f Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Wed, 3 Oct 2018 22:29:32 +0200
+Subject: [PATCH] comm.h needed for list_{display,generic}.o
+
+comm.h is needed to build list_display.o and list_generic.o otherwise
+parallel builds will sometimes fail
+
+Fixes:
+ - http://autobuild.buildroot.org/results/43105f14857dbe72d8878fc7b3db67f7bdca93cc
+ - http://autobuild.buildroot.org/results/47f4ecbec1355285633df287fc9c4e7cccde9378
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Upstream status: https://savannah.gnu.org/bugs/index.php?54776]
+---
+ Makefile.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index af5938b..e6d5247 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -265,7 +265,7 @@  braille.h
+ viewport.o: layout.h viewport.h canvas.h viewport.c config.h screen.h os.h osdef.h ansi.h acls.h \
+  comm.h layer.h term.h image.h display.h window.h extern.h \
+  braille.h
+-list_generic.o: list_generic.h list_generic.c layer.h screen.h osdef.h
+-list_display.o: list_generic.h list_display.c layer.h screen.h osdef.h
++list_generic.o: list_generic.h list_generic.c layer.h screen.h osdef.h comm.h
++list_display.o: list_generic.h list_display.c layer.h screen.h osdef.h comm.h
+ list_window.o: list_generic.h list_window.c window.h layer.h screen.h osdef.h comm.h
+ 
+-- 
+2.17.1
+