diff mbox series

xlib_libXdmcp: add missing dependency on host-pkgconf

Message ID 20180921121350.22638-1-thomas.petazzoni@bootlin.com
State Accepted
Headers show
Series xlib_libXdmcp: add missing dependency on host-pkgconf | expand

Commit Message

Thomas Petazzoni Sept. 21, 2018, 12:13 p.m. UTC
The libXdmcp configure script uses pkg-config, but the Buildroot
package does not depend on host-pkgconf. This is not seen by the
autobuilders most likely because another package that is always built
before libXdmcp builds pkg-config.

However, running:

$ make xlib_libXdmcp

triggers the following build failure:

checking pkg-config is at least version 0.9.0... ./configure: line 12323: /home/thomas/projets/buildroot/output/host/bin/pkg-config: No such file or directory
no
[...]
checking for XDMCP... configure: error: in `/home/thomas/projets/buildroot/output/build/xlib_libXdmcp-1.1.2':
configure: error: The pkg-config script could not be found or is too old.  Make sure it
is in your PATH or set the PKG_CONFIG environment variable to the full
path to pkg-config.

This was detected using per-package target/host folders, because with
this, only the dependencies explicitly expressed by a package are
available to the package.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
---
 package/x11r7/xlib_libXdmcp/xlib_libXdmcp.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Sept. 25, 2018, 9:18 p.m. UTC | #1
Hello,

On Fri, 21 Sep 2018 14:13:50 +0200, Thomas Petazzoni wrote:
> The libXdmcp configure script uses pkg-config, but the Buildroot
> package does not depend on host-pkgconf. This is not seen by the
> autobuilders most likely because another package that is always built
> before libXdmcp builds pkg-config.
> 
> However, running:
> 
> $ make xlib_libXdmcp
> 
> triggers the following build failure:
> 
> checking pkg-config is at least version 0.9.0... ./configure: line 12323: /home/thomas/projets/buildroot/output/host/bin/pkg-config: No such file or directory
> no
> [...]
> checking for XDMCP... configure: error: in `/home/thomas/projets/buildroot/output/build/xlib_libXdmcp-1.1.2':
> configure: error: The pkg-config script could not be found or is too old.  Make sure it
> is in your PATH or set the PKG_CONFIG environment variable to the full
> path to pkg-config.
> 
> This was detected using per-package target/host folders, because with
> this, only the dependencies explicitly expressed by a package are
> available to the package.
> 
> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
> ---
>  package/x11r7/xlib_libXdmcp/xlib_libXdmcp.mk | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)

Applied to master, thanks.

Thomas
Bernd Kuhls Sept. 30, 2018, 7:43 a.m. UTC | #2
Am Fri, 21 Sep 2018 14:13:50 +0200 schrieb Thomas Petazzoni:

> This was detected using per-package target/host folders, because with
> this, only the dependencies explicitly expressed by a package are
> available to the package.

Hi Thomas,

is the current patch series for per-package target/host folders publicly 
available?

Regards, Bernd
Thomas Petazzoni Oct. 1, 2018, 6:43 a.m. UTC | #3
Hello,

On Sun, 30 Sep 2018 09:43:22 +0200, Bernd Kuhls wrote:

> is the current patch series for per-package target/host folders publicly 
> available?

No, I am in the process of cleaning it up and I'll post it when it's
ready. I started a private autobuilder instance that tests the
per-package target/host folders, and that's how I found all these
issues (and I have more coming).

Best regards,

Thomas
Peter Korsgaard Oct. 5, 2018, 5:43 p.m. UTC | #4
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@bootlin.com> writes:

 > The libXdmcp configure script uses pkg-config, but the Buildroot
 > package does not depend on host-pkgconf. This is not seen by the
 > autobuilders most likely because another package that is always built
 > before libXdmcp builds pkg-config.

 > However, running:

 > $ make xlib_libXdmcp

 > triggers the following build failure:

 > checking pkg-config is at least version 0.9.0... ./configure: line
 > 12323: /home/thomas/projets/buildroot/output/host/bin/pkg-config: No
 > such file or directory
 > no
 > [...]
 > checking for XDMCP... configure: error: in `/home/thomas/projets/buildroot/output/build/xlib_libXdmcp-1.1.2':
 > configure: error: The pkg-config script could not be found or is too old.  Make sure it
 > is in your PATH or set the PKG_CONFIG environment variable to the full
 > path to pkg-config.

 > This was detected using per-package target/host folders, because with
 > this, only the dependencies explicitly expressed by a package are
 > available to the package.

 > Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>

Committed to 2018.08.x, thanks.
diff mbox series

Patch

diff --git a/package/x11r7/xlib_libXdmcp/xlib_libXdmcp.mk b/package/x11r7/xlib_libXdmcp/xlib_libXdmcp.mk
index 179234e73f..44a6f00543 100644
--- a/package/x11r7/xlib_libXdmcp/xlib_libXdmcp.mk
+++ b/package/x11r7/xlib_libXdmcp/xlib_libXdmcp.mk
@@ -10,8 +10,8 @@  XLIB_LIBXDMCP_SITE = http://xorg.freedesktop.org/releases/individual/lib
 XLIB_LIBXDMCP_LICENSE = MIT
 XLIB_LIBXDMCP_LICENSE_FILES = COPYING
 XLIB_LIBXDMCP_INSTALL_STAGING = YES
-XLIB_LIBXDMCP_DEPENDENCIES = xutil_util-macros xorgproto
-HOST_XLIB_LIBXDMCP_DEPENDENCIES = host-xutil_util-macros host-xorgproto
+XLIB_LIBXDMCP_DEPENDENCIES = xutil_util-macros xorgproto host-pkgconf
+HOST_XLIB_LIBXDMCP_DEPENDENCIES = host-xutil_util-macros host-xorgproto host-pkgconf
 
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))