diff mbox series

[v2] libostree: override path to gpg-error-config

Message ID 20180726080800.5564-1-marcus.folkesson@gmail.com
State Superseded
Headers show
Series [v2] libostree: override path to gpg-error-config | expand

Commit Message

Marcus Folkesson July 26, 2018, 8:08 a.m. UTC
libostree has begun to use `gpg-error-config` in their configuration
script.
Point out gpg-error-config in staging dir to avoid using the one
installed on the host system.

Fixes:
 http://autobuild.buildroot.net/results/447b96e449e881cf1bd9644cda0f386aa4c75724

Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
---

Notes:
    v2:
    	- override ac_cv_path_GPG_ERROR_CONFIG instead of  GPG_ERROR_CONFIG

 package/libostree/libostree.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Marcus Folkesson July 26, 2018, 8:11 a.m. UTC | #1
On Thu, Jul 26, 2018 at 10:08:00AM +0200, Marcus Folkesson wrote:
> libostree has begun to use `gpg-error-config` in their configuration
> script.
> Point out gpg-error-config in staging dir to avoid using the one
> installed on the host system.
> 
> Fixes:
>  http://autobuild.buildroot.net/results/447b96e449e881cf1bd9644cda0f386aa4c75724
> 
> Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
> ---
> 
> Notes:
>     v2:
>     	- override ac_cv_path_GPG_ERROR_CONFIG instead of  GPG_ERROR_CONFIG

Eum...

		- override GPG_ERROR_CONFIG instead of ac_cv_path_GPG_ERROR_CONFIG

:-)

> 
>  package/libostree/libostree.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/libostree/libostree.mk b/package/libostree/libostree.mk
> index 24eda0d1db..414cca104a 100644
> --- a/package/libostree/libostree.mk
> +++ b/package/libostree/libostree.mk
> @@ -12,6 +12,7 @@ LIBOSTREE_LICENSE = LGPL-2.0+
>  LIBOSTREE_LICENSE_FILES = COPYING
>  LIBOSTREE_DEPENDENCIES = e2fsprogs host-bison host-pkgconf libfuse libglib2 libgpgme xz
>  LIBOSTREE_INSTALL_STAGING = YES
> +LIBOSTREE_CONF_ENV = GPG_ERROR_CONFIG=$(STAGING_DIR)/usr/bin/gpg-error-config
>  
>  LIBOSTREE_CONF_OPTS += \
>  	--with-gpgme-prefix=$(STAGING_DIR)/usr \
> -- 
> 2.18.0
>
Arnout Vandecappelle July 26, 2018, 8:40 a.m. UTC | #2
On 26-07-18 10:08, Marcus Folkesson wrote:
> libostree has begun to use `gpg-error-config` in their configuration
> script.
> Point out gpg-error-config in staging dir to avoid using the one
> installed on the host system.
> 
> Fixes:
>  http://autobuild.buildroot.net/results/447b96e449e881cf1bd9644cda0f386aa4c75724
> 
> Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>

Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

 Regards,
 Arnout

> ---
> 
> Notes:
>     v2:
>     	- override ac_cv_path_GPG_ERROR_CONFIG instead of  GPG_ERROR_CONFIG
> 
>  package/libostree/libostree.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/libostree/libostree.mk b/package/libostree/libostree.mk
> index 24eda0d1db..414cca104a 100644
> --- a/package/libostree/libostree.mk
> +++ b/package/libostree/libostree.mk
> @@ -12,6 +12,7 @@ LIBOSTREE_LICENSE = LGPL-2.0+
>  LIBOSTREE_LICENSE_FILES = COPYING
>  LIBOSTREE_DEPENDENCIES = e2fsprogs host-bison host-pkgconf libfuse libglib2 libgpgme xz
>  LIBOSTREE_INSTALL_STAGING = YES
> +LIBOSTREE_CONF_ENV = GPG_ERROR_CONFIG=$(STAGING_DIR)/usr/bin/gpg-error-config
>  
>  LIBOSTREE_CONF_OPTS += \
>  	--with-gpgme-prefix=$(STAGING_DIR)/usr \
>
Thomas Petazzoni July 26, 2018, 1:27 p.m. UTC | #3
Hello,

On Thu, 26 Jul 2018 10:08:00 +0200, Marcus Folkesson wrote:
> libostree has begun to use `gpg-error-config` in their configuration
> script.
> Point out gpg-error-config in staging dir to avoid using the one
> installed on the host system.
> 
> Fixes:
>  http://autobuild.buildroot.net/results/447b96e449e881cf1bd9644cda0f386aa4c75724
> 
> Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
> ---
> 
> Notes:
>     v2:
>     	- override ac_cv_path_GPG_ERROR_CONFIG instead of  GPG_ERROR_CONFIG
> 
>  package/libostree/libostree.mk | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/package/libostree/libostree.mk b/package/libostree/libostree.mk
> index 24eda0d1db..414cca104a 100644
> --- a/package/libostree/libostree.mk
> +++ b/package/libostree/libostree.mk
> @@ -12,6 +12,7 @@ LIBOSTREE_LICENSE = LGPL-2.0+
>  LIBOSTREE_LICENSE_FILES = COPYING
>  LIBOSTREE_DEPENDENCIES = e2fsprogs host-bison host-pkgconf libfuse libglib2 libgpgme xz
>  LIBOSTREE_INSTALL_STAGING = YES
> +LIBOSTREE_CONF_ENV = GPG_ERROR_CONFIG=$(STAGING_DIR)/usr/bin/gpg-error-config

So libostree is using libgpg-error directly, not only indirectly
through libgpgme. Should we add libgpg-error in libostree dependencies
explicitly to document this direct dependency ?

It is a bit weird to pass GPG_ERROR_CONFIG with this package not
depending on libgpg-error.

Best regards,

Thomas
Marcus Folkesson July 26, 2018, 1:52 p.m. UTC | #4
Hello,

On Thu, Jul 26, 2018 at 03:27:14PM +0200, Thomas Petazzoni wrote:
> Hello,
> 
> On Thu, 26 Jul 2018 10:08:00 +0200, Marcus Folkesson wrote:
> > libostree has begun to use `gpg-error-config` in their configuration
> > script.
> > Point out gpg-error-config in staging dir to avoid using the one
> > installed on the host system.
> > 
> > Fixes:
> >  http://autobuild.buildroot.net/results/447b96e449e881cf1bd9644cda0f386aa4c75724
> > 
> > Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
> > ---
> > 
> > Notes:
> >     v2:
> >     	- override ac_cv_path_GPG_ERROR_CONFIG instead of  GPG_ERROR_CONFIG
> > 
> >  package/libostree/libostree.mk | 1 +
> >  1 file changed, 1 insertion(+)
> > 
> > diff --git a/package/libostree/libostree.mk b/package/libostree/libostree.mk
> > index 24eda0d1db..414cca104a 100644
> > --- a/package/libostree/libostree.mk
> > +++ b/package/libostree/libostree.mk
> > @@ -12,6 +12,7 @@ LIBOSTREE_LICENSE = LGPL-2.0+
> >  LIBOSTREE_LICENSE_FILES = COPYING
> >  LIBOSTREE_DEPENDENCIES = e2fsprogs host-bison host-pkgconf libfuse libglib2 libgpgme xz
> >  LIBOSTREE_INSTALL_STAGING = YES
> > +LIBOSTREE_CONF_ENV = GPG_ERROR_CONFIG=$(STAGING_DIR)/usr/bin/gpg-error-config
> 
> So libostree is using libgpg-error directly, not only indirectly
> through libgpgme. Should we add libgpg-error in libostree dependencies
> explicitly to document this direct dependency ?

That would be good. I will add it in v3. Thanks

> 
> It is a bit weird to pass GPG_ERROR_CONFIG with this package not
> depending on libgpg-error.
> 
> Best regards,
> 
> Thomas
> -- 
> Thomas Petazzoni, CTO, Bootlin (formerly Free Electrons)
> Embedded Linux and Kernel engineering
> https://bootlin.com


Best regards
Marcus Folkesson
diff mbox series

Patch

diff --git a/package/libostree/libostree.mk b/package/libostree/libostree.mk
index 24eda0d1db..414cca104a 100644
--- a/package/libostree/libostree.mk
+++ b/package/libostree/libostree.mk
@@ -12,6 +12,7 @@  LIBOSTREE_LICENSE = LGPL-2.0+
 LIBOSTREE_LICENSE_FILES = COPYING
 LIBOSTREE_DEPENDENCIES = e2fsprogs host-bison host-pkgconf libfuse libglib2 libgpgme xz
 LIBOSTREE_INSTALL_STAGING = YES
+LIBOSTREE_CONF_ENV = GPG_ERROR_CONFIG=$(STAGING_DIR)/usr/bin/gpg-error-config
 
 LIBOSTREE_CONF_OPTS += \
 	--with-gpgme-prefix=$(STAGING_DIR)/usr \