diff mbox series

[1/1] yaml-cpp: disable tests

Message ID 20180611045144.18669-1-fontaine.fabrice@gmail.com
State Accepted
Commit 693b27e2252afbf7f31e9e7a8e7a661c18bb288a
Headers show
Series [1/1] yaml-cpp: disable tests | expand

Commit Message

Fabrice Fontaine June 11, 2018, 4:51 a.m. UTC
fork is used in tests so build fails without MMU

Fixes:
- http://autobuild.buildroot.net/results/3cb7c4d93e466c6eef69aacd0e561a9fb569e69b

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/yaml-cpp/yaml-cpp.mk | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard June 11, 2018, 7:35 p.m. UTC | #1
>>>>> "Fabrice" == Fabrice Fontaine <fontaine.fabrice@gmail.com> writes:

 > fork is used in tests so build fails without MMU
 > Fixes:
 > - http://autobuild.buildroot.net/results/3cb7c4d93e466c6eef69aacd0e561a9fb569e69b

 > Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/yaml-cpp/yaml-cpp.mk b/package/yaml-cpp/yaml-cpp.mk
index d97c84a7cf..97021ea421 100644
--- a/package/yaml-cpp/yaml-cpp.mk
+++ b/package/yaml-cpp/yaml-cpp.mk
@@ -11,6 +11,8 @@  YAML_CPP_LICENSE = MIT
 YAML_CPP_LICENSE_FILES = LICENSE
 
 # Disable testing and parse tools
-YAML_CPP_CONF_OPTS += -DYAML_CPP_BUILD_TOOLS=OFF
+YAML_CPP_CONF_OPTS += \
+	-DYAML_CPP_BUILD_TESTS=OFF \
+	-DYAML_CPP_BUILD_TOOLS=OFF
 
 $(eval $(cmake-package))