diff mbox series

[1/1] package/znc: python support depends on icu

Message ID 20180509172553.856-1-bernd.kuhls@t-online.de
State Accepted
Headers show
Series [1/1] package/znc: python support depends on icu | expand

Commit Message

Bernd Kuhls May 9, 2018, 5:25 p.m. UTC
Upstream checks for icu when build with python support:
https://github.com/znc/znc/commit/4fe4a45dd62411ba9ede04750ca44f071e7d6cbb

Fixes
http://autobuild.buildroot.net/results/9e4/9e44159820789f1d25efcbd24318b0e05e132371/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
 package/znc/znc.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Yann E. MORIN May 12, 2018, 3:01 p.m. UTC | #1
Bernd, All,

On 2018-05-09 19:25 +0200, Bernd Kuhls spake thusly:
> Upstream checks for icu when build with python support:
> https://github.com/znc/znc/commit/4fe4a45dd62411ba9ede04750ca44f071e7d6cbb
> 
> Fixes
> http://autobuild.buildroot.net/results/9e4/9e44159820789f1d25efcbd24318b0e05e132371/
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/znc/znc.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/package/znc/znc.mk b/package/znc/znc.mk
> index 33ac266dd3..2a04c66377 100644
> --- a/package/znc/znc.mk
> +++ b/package/znc/znc.mk
> @@ -32,7 +32,8 @@ else
>  ZNC_CONF_OPTS += --disable-zlib
>  endif
>  
> -ifeq ($(BR2_PACKAGE_PYTHON3),y)
> +# python support depends on icu
> +ifeq ($(BR2_PACKAGE_ICU)$(BR2_PACKAGE_PYTHON3),yy)

There is already an ICU conditrional above, so I was wondering if we
could comonalise the code...

In the end, I am not so sure that is important, though, so:

Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

>  ZNC_DEPENDENCIES += python3 host-swig
>  ZNC_CONF_OPTS += --enable-python=python3
>  else
> -- 
> 2.14.2
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni May 13, 2018, 7:46 p.m. UTC | #2
Hello,

On Wed,  9 May 2018 19:25:53 +0200, Bernd Kuhls wrote:
> Upstream checks for icu when build with python support:
> https://github.com/znc/znc/commit/4fe4a45dd62411ba9ede04750ca44f071e7d6cbb
> 
> Fixes
> http://autobuild.buildroot.net/results/9e4/9e44159820789f1d25efcbd24318b0e05e132371/
> 
> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
> ---
>  package/znc/znc.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
Peter Korsgaard Aug. 23, 2018, 7:36 p.m. UTC | #3
>>>>> "Bernd" == Bernd Kuhls <bernd.kuhls@t-online.de> writes:

 > Upstream checks for icu when build with python support:
 > https://github.com/znc/znc/commit/4fe4a45dd62411ba9ede04750ca44f071e7d6cbb

 > Fixes
 > http://autobuild.buildroot.net/results/9e4/9e44159820789f1d25efcbd24318b0e05e132371/

 > Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>

Committed to 2018.02.x, thanks.
diff mbox series

Patch

diff --git a/package/znc/znc.mk b/package/znc/znc.mk
index 33ac266dd3..2a04c66377 100644
--- a/package/znc/znc.mk
+++ b/package/znc/znc.mk
@@ -32,7 +32,8 @@  else
 ZNC_CONF_OPTS += --disable-zlib
 endif
 
-ifeq ($(BR2_PACKAGE_PYTHON3),y)
+# python support depends on icu
+ifeq ($(BR2_PACKAGE_ICU)$(BR2_PACKAGE_PYTHON3),yy)
 ZNC_DEPENDENCIES += python3 host-swig
 ZNC_CONF_OPTS += --enable-python=python3
 else