diff mbox series

[1/1] msmtp: add optional libidn dependency

Message ID 20180501194910.25916-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] msmtp: add optional libidn dependency | expand

Commit Message

Fabrice Fontaine May 1, 2018, 7:49 p.m. UTC
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/msmtp/msmtp.mk | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)

Comments

Thomas Petazzoni May 1, 2018, 8:16 p.m. UTC | #1
Hello,

On Tue,  1 May 2018 21:49:10 +0200, Fabrice Fontaine wrote:
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/msmtp/msmtp.mk | 11 ++++++++---
>  1 file changed, 8 insertions(+), 3 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/msmtp/msmtp.mk b/package/msmtp/msmtp.mk
index b7a830649d..65fd0e4319 100644
--- a/package/msmtp/msmtp.mk
+++ b/package/msmtp/msmtp.mk
@@ -8,9 +8,7 @@  MSMTP_VERSION = 1.6.6
 MSMTP_SITE = http://downloads.sourceforge.net/project/msmtp/msmtp/$(MSMTP_VERSION)
 MSMTP_SOURCE = msmtp-$(MSMTP_VERSION).tar.xz
 MSMTP_DEPENDENCIES = host-pkgconf
-MSMTP_CONF_OPTS = \
-	--without-libidn \
-	--disable-gai-idn
+MSMTP_CONF_OPTS = --disable-gai-idn
 MSMTP_LICENSE = GPL-3.0+
 MSMTP_LICENSE_FILES = COPYING
 
@@ -21,6 +19,13 @@  else
 MSMTP_CONF_OPTS += --without-libgsasl
 endif
 
+ifeq ($(BR2_PACKAGE_LIBIDN),y)
+MSMTP_CONF_OPTS += --with-libidn
+MSMTP_DEPENDENCIES += libidn
+else
+MSMTP_CONF_OPTS += --without-libidn
+endif
+
 ifeq ($(BR2_PACKAGE_LIBSECRET),y)
 MSMTP_CONF_OPTS += --with-libsecret
 MSMTP_DEPENDENCIES += libsecret