diff mbox series

[1/4] package/mesa3d: radeonSI: specify drm platform

Message ID 20180428172803.11179-1-romain.naour@gmail.com
State Accepted
Headers show
Series [1/4] package/mesa3d: radeonSI: specify drm platform | expand

Commit Message

Romain Naour April 28, 2018, 5:28 p.m. UTC
When BR2_PACKAGE_MESA3D_OPENGL_EGL is selected with RadeonSI drvier,
mesa platform must be specified with drm.

Fixes:
hecking for RADEON... yes
checking for AMDGPU... yes
configure: error: radeonsi requires one of these:
                  1) --with-platforms=drm (X, Wayland, offscreen rendering based on DRM)
                  2) --with-platforms=surfaceless (offscreen only)
                  3) --with-platforms=android (Android only)
                  Recommended options: drm,x11

Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
 package/mesa3d/mesa3d.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Thomas Petazzoni May 1, 2018, 8:57 p.m. UTC | #1
Hello,

On Sat, 28 Apr 2018 19:28:00 +0200, Romain Naour wrote:
> When BR2_PACKAGE_MESA3D_OPENGL_EGL is selected with RadeonSI drvier,
> mesa platform must be specified with drm.
> 
> Fixes:
> hecking for RADEON... yes
> checking for AMDGPU... yes
> configure: error: radeonsi requires one of these:
>                   1) --with-platforms=drm (X, Wayland, offscreen rendering based on DRM)
>                   2) --with-platforms=surfaceless (offscreen only)
>                   3) --with-platforms=android (Android only)
>                   Recommended options: drm,x11
> 
> Signed-off-by: Romain Naour <romain.naour@gmail.com>
> ---
>  package/mesa3d/mesa3d.mk | 2 ++
>  1 file changed, 2 insertions(+)

Entire series applied. Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/mesa3d/mesa3d.mk b/package/mesa3d/mesa3d.mk
index 9857b597cf..7534bc0833 100644
--- a/package/mesa3d/mesa3d.mk
+++ b/package/mesa3d/mesa3d.mk
@@ -167,6 +167,8 @@  else ifeq ($(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_ETNAVIV),y)
 MESA3D_PLATFORMS = drm
 else ifeq ($(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_VIRGL),y)
 MESA3D_PLATFORMS = drm
+else ifeq ($(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER_RADEONSI),y)
+MESA3D_PLATFORMS = drm
 endif
 ifeq ($(BR2_PACKAGE_WAYLAND),y)
 MESA3D_DEPENDENCIES += wayland wayland-protocols