diff mbox series

waf: fix autobuilders failure

Message ID 20180402171427.24300-1-maxime.hadjinlian@gmail.com
State Accepted
Headers show
Series waf: fix autobuilders failure | expand

Commit Message

Maxime Hadjinlian April 2, 2018, 5:14 p.m. UTC
The package is host only and so the variable to use must be prefixed by
'HOST_'

Fixes:
	http://autobuild.buildroot.org/results/01d/01d8c21df4baa9ecc6a0e45744fe6a4d086a0652/

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
---
 package/waf/waf.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni April 2, 2018, 7:43 p.m. UTC | #1
Hello,

On Mon,  2 Apr 2018 19:14:27 +0200, Maxime Hadjinlian wrote:
> The package is host only and so the variable to use must be prefixed by
> 'HOST_'
> 
> Fixes:
> 	http://autobuild.buildroot.org/results/01d/01d8c21df4baa9ecc6a0e45744fe6a4d086a0652/
> 
> Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
> ---
>  package/waf/waf.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

Applied to master after adjusting the commit title and commit log.
Thanks!

However, I really think packages shouldn't have to use
HOST_<pkg>_DL_DIR, and therefore the infra should probably define
<pkg>_DL_DIR.

Thomas
diff mbox series

Patch

diff --git a/package/waf/waf.mk b/package/waf/waf.mk
index 639c26a3b0..cb738a38fd 100644
--- a/package/waf/waf.mk
+++ b/package/waf/waf.mk
@@ -9,7 +9,7 @@  WAF_SOURCE = waf-$(WAF_VERSION)
 WAF_SITE = https://waf.io/
 
 define HOST_WAF_EXTRACT_CMDS
-	$(INSTALL) -D -m 0755 $(WAF_DL_DIR)/waf-$(WAF_VERSION) $(@D)/waf
+	$(INSTALL) -D -m 0755 $(HOST_WAF_DL_DIR)/waf-$(WAF_VERSION) $(@D)/waf
 endef
 
 define HOST_WAF_INSTALL_CMDS