diff mbox series

[v5,05/11] pkg-generic: add a subdirectory to the DL_DIR

Message ID 20180402130934.19274-5-maxime.hadjinlian@gmail.com
State Superseded
Headers show
Series [v5,01/11] packages: use new $($PKG)_DL_DIR) variable | expand

Commit Message

Maxime Hadjinlian April 2, 2018, 1:09 p.m. UTC
With all the previous changes, we are now ready to add a subdirectory to
the DL_DIR.
The structure will now be DL_DIR/PKG_NAME/{FILE1,FILE2}

This is needed for multiple reasons:
    - Avoid patches with name like SHA1.patch laying flat in DL_DIR,
    which makes it hard to know to which packages they apply
    - Avoid possible collisions if two releases have the same name
    (e.g: v01.tar)
    - Allow the possibility to handle a git cache per package in the
    newly created subdirectory.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
 package/pkg-generic.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard April 2, 2018, 2:28 p.m. UTC | #1
>>>>> "Maxime" == Maxime Hadjinlian <maxime.hadjinlian@gmail.com> writes:

 > With all the previous changes, we are now ready to add a subdirectory to
 > the DL_DIR.
 > The structure will now be DL_DIR/PKG_NAME/{FILE1,FILE2}

 > This is needed for multiple reasons:
 >     - Avoid patches with name like SHA1.patch laying flat in DL_DIR,
 >     which makes it hard to know to which packages they apply
 >     - Avoid possible collisions if two releases have the same name
 >     (e.g: v01.tar)
 >     - Allow the possibility to handle a git cache per package in the
 >     newly created subdirectory.

 > Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
 > Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Committed, thanks.
diff mbox series

Patch

diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index 01d61ac0ad..20ee73d438 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -432,7 +432,7 @@  endif
 
 $(2)_BASENAME	= $$(if $$($(2)_VERSION),$(1)-$$($(2)_VERSION),$(1))
 $(2)_BASENAME_RAW = $$(if $$($(2)_VERSION),$$($(2)_RAWNAME)-$$($(2)_VERSION),$$($(2)_RAWNAME))
-$(2)_DL_DIR	=  $$(DL_DIR)
+$(2)_DL_DIR 	=  $$(DL_DIR)/$$($(2)_RAWNAME)
 $(2)_DIR	=  $$(BUILD_DIR)/$$($(2)_BASENAME)
 
 ifndef $(2)_SUBDIR