diff mbox series

[1/1] mpv: enable cdda support through libcdio-paranoia

Message ID 20180401193653.18235-1-fontaine.fabrice@gmail.com
State Accepted
Headers show
Series [1/1] mpv: enable cdda support through libcdio-paranoia | expand

Commit Message

Fabrice Fontaine April 1, 2018, 7:36 p.m. UTC
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
 package/mpv/mpv.mk | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni April 1, 2018, 10:44 p.m. UTC | #1
Hello,

On Sun,  1 Apr 2018 21:36:53 +0200, Fabrice Fontaine wrote:
> Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
> ---
>  package/mpv/mpv.mk | 9 ++++++++-
>  1 file changed, 8 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/mpv/mpv.mk b/package/mpv/mpv.mk
index f38a6b916f..b8260213b7 100644
--- a/package/mpv/mpv.mk
+++ b/package/mpv/mpv.mk
@@ -20,7 +20,6 @@  MPV_CONF_OPTS = \
 	--prefix=/usr \
 	--disable-android \
 	--disable-caca \
-	--disable-cdda \
 	--disable-cocoa \
 	--disable-coreaudio \
 	--disable-cuda-hwaccel \
@@ -99,6 +98,14 @@  else
 MPV_CONF_OPTS += --disable-libbluray
 endif
 
+# libcdio-paranoia
+ifeq ($(BR2_PACKAGE_LIBCDIO_PARANOIA),y)
+MPV_CONF_OPTS += --enable-cdda
+MPV_DEPENDENCIES += libcdio-paranoia
+else
+MPV_CONF_OPTS += --disable-cdda
+endif
+
 # libdvdnav
 ifeq ($(BR2_PACKAGE_LIBDVDNAV),y)
 MPV_CONF_OPTS += --enable-dvdnav