diff mbox series

[1/2] package/fmc: Remove hash check

Message ID 20180119181743.30625-1-matthew.weber@rockwellcollins.com
State Rejected
Headers show
Series [1/2] package/fmc: Remove hash check | expand

Commit Message

Matt Weber Jan. 19, 2018, 6:17 p.m. UTC
This package uses a kconfig value for the version,
so ignore the hash check which will fail when the
user specifies something other then the kconfig default.

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
---
 package/fmc/fmc.hash | 2 --
 package/fmc/fmc.mk   | 2 ++
 2 files changed, 2 insertions(+), 2 deletions(-)
 delete mode 100644 package/fmc/fmc.hash

Comments

Arnout Vandecappelle Jan. 22, 2018, 9:33 p.m. UTC | #1
On 19-01-18 19:17, Matt Weber wrote:
> This package uses a kconfig value for the version,

 Huh?

FMC_VERSION = fsl-sdk-v2.0

 Do you have a local patch maybe?

 Regards,
 Arnout

> so ignore the hash check which will fail when the
> user specifies something other then the kconfig default.
> 
> Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
> ---
>  package/fmc/fmc.hash | 2 --
>  package/fmc/fmc.mk   | 2 ++
>  2 files changed, 2 insertions(+), 2 deletions(-)
>  delete mode 100644 package/fmc/fmc.hash
> 
> diff --git a/package/fmc/fmc.hash b/package/fmc/fmc.hash
> deleted file mode 100644
> index 13d9d77ee5..0000000000
> --- a/package/fmc/fmc.hash
> +++ /dev/null
> @@ -1,2 +0,0 @@
> -# Locally calculated
> -sha256	a91e0c9b7c7f238634c64a755c05671f33f2acdb6ae2d09cad4d683b364ee8e4	fmc-fsl-sdk-v2.0.tar.gz
> diff --git a/package/fmc/fmc.mk b/package/fmc/fmc.mk
> index 2a95fec0b7..5dda914858 100644
> --- a/package/fmc/fmc.mk
> +++ b/package/fmc/fmc.mk
> @@ -10,6 +10,8 @@ FMC_LICENSE = MIT
>  FMC_LICENSE_FILES = COPYING
>  FMC_DEPENDENCIES = libxml2 tclap fmlib
>  
> +BR_NO_CHECK_HASH_FOR += $(FMC_SOURCE)
> +
>  FMC_MAKE_OPTS = \
>  	CC="$(TARGET_CC)" \
>  	CXX="$(TARGET_CXX)" \
>
Matt Weber Jan. 22, 2018, 10:46 p.m. UTC | #2
Arnout,

On Mon, Jan 22, 2018 at 3:33 PM, Arnout Vandecappelle <arnout@mind.be> wrote:
>
>
> On 19-01-18 19:17, Matt Weber wrote:
>> This package uses a kconfig value for the version,
>
>  Huh?
>
> FMC_VERSION = fsl-sdk-v2.0
>
>  Do you have a local patch maybe?
>

:-(  Shoot I do.  I will be including more changes in my v2.

Matt
diff mbox series

Patch

diff --git a/package/fmc/fmc.hash b/package/fmc/fmc.hash
deleted file mode 100644
index 13d9d77ee5..0000000000
--- a/package/fmc/fmc.hash
+++ /dev/null
@@ -1,2 +0,0 @@ 
-# Locally calculated
-sha256	a91e0c9b7c7f238634c64a755c05671f33f2acdb6ae2d09cad4d683b364ee8e4	fmc-fsl-sdk-v2.0.tar.gz
diff --git a/package/fmc/fmc.mk b/package/fmc/fmc.mk
index 2a95fec0b7..5dda914858 100644
--- a/package/fmc/fmc.mk
+++ b/package/fmc/fmc.mk
@@ -10,6 +10,8 @@  FMC_LICENSE = MIT
 FMC_LICENSE_FILES = COPYING
 FMC_DEPENDENCIES = libxml2 tclap fmlib
 
+BR_NO_CHECK_HASH_FOR += $(FMC_SOURCE)
+
 FMC_MAKE_OPTS = \
 	CC="$(TARGET_CC)" \
 	CXX="$(TARGET_CXX)" \