diff mbox series

libostree: make sure libavahi-client is built

Message ID 20171221231932.31913-1-marcus.folkesson@gmail.com
State Accepted
Headers show
Series libostree: make sure libavahi-client is built | expand

Commit Message

Marcus Folkesson Dec. 21, 2017, 11:19 p.m. UTC
Avahi support also needs libavahi-client, which is built by avahi if avahi-daemon
and dbus is selected.

Fixes:
http://autobuild.buildroot.net/results/1edfb60add17945eabc557e1dbfb08a0ba466df9/

Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
---
 package/libostree/libostree.mk | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

Comments

Matt Weber Dec. 26, 2017, 4:16 a.m. UTC | #1
Marcus,

On Thu, Dec 21, 2017 at 5:19 PM, Marcus Folkesson
<marcus.folkesson@gmail.com> wrote:
> Avahi support also needs libavahi-client, which is built by avahi if avahi-daemon
> and dbus is selected.
>
> Fixes:
> http://autobuild.buildroot.net/results/1edfb60add17945eabc557e1dbfb08a0ba466df9/
>
> Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
> ---
>  package/libostree/libostree.mk | 8 ++++++--
>  1 file changed, 6 insertions(+), 2 deletions(-)
>
> diff --git a/package/libostree/libostree.mk b/package/libostree/libostree.mk
> index 612c284870..f0aeb8d72a 100644
> --- a/package/libostree/libostree.mk
> +++ b/package/libostree/libostree.mk
> @@ -27,9 +27,13 @@ else
>  LIBOSTREE_CONF_OPTS += --without-openssl
>  endif
>
> -ifeq ($(BR2_PACKAGE_AVAHI),y)
> +# Avahi support needs libavahi-client, which is built by avahi if avahi-daemon
> +# and dbus is selected. Since there is no BR2_PACKAGE_LIBAVAHI_CLIENT config
> +# option yet, use the avahi-daemon and dbus config symbols to check for
> +# libavahi-client.
> +ifeq ($(BR2_PACKAGE_AVAHI_DAEMON)$(BR2_PACKAGE_DBUS),yy)
>  LIBOSTREE_CONF_OPTS += --with-avahi
> -LIBOSTREE_DEPENDENCIES += avahi
> +LIBOSTREE_DEPENDENCIES += avahi dbus

I patched the failing build and it now builds.

Tested-by: Matt Weber <matthew.weber@rockwellcollins.com>

I've kicked off a validation using utils/test-pkg with the following
config and both of your libostree patches applied.
BR2_TOOLCHAIN_USES_GLIBC=y
BR2_PACKAGE_LIBOSTREE=y
BR2_PACKAGE_E2FSPROGS=y
BR2_PACKAGE_LIBFUSE=y
BR2_PACKAGE_LIBGLIB2=y
BR2_PACKAGE_LIBGPGME=y
BR2_PACKAGE_XZ=y
BR2_PACKAGE_AVAHI=y
BR2_PACKAGE_AVAHI_DAEMON=y
BR2_PACKAGE_DBUS=y

If anything pops up, I'll respond here tomorrow.

Matt
Matt Weber Dec. 26, 2017, 8:06 p.m. UTC | #2
Marcus,

On Mon, Dec 25, 2017 at 10:16 PM, Matthew Weber
<matthew.weber@rockwellcollins.com> wrote:
> Marcus,
>
> On Thu, Dec 21, 2017 at 5:19 PM, Marcus Folkesson
> <marcus.folkesson@gmail.com> wrote:
>> Avahi support also needs libavahi-client, which is built by avahi if avahi-daemon
>> and dbus is selected.
>>
>> Fixes:
>> http://autobuild.buildroot.net/results/1edfb60add17945eabc557e1dbfb08a0ba466df9/
>>
[snip]

>
> Tested-by: Matt Weber <matthew.weber@rockwellcollins.com>
>
> I've kicked off a validation using utils/test-pkg with the following
> config and both of your libostree patches applied.
> BR2_TOOLCHAIN_USES_GLIBC=y
> BR2_PACKAGE_LIBOSTREE=y
> BR2_PACKAGE_E2FSPROGS=y
> BR2_PACKAGE_LIBFUSE=y
> BR2_PACKAGE_LIBGLIB2=y
> BR2_PACKAGE_LIBGPGME=y
> BR2_PACKAGE_XZ=y
> BR2_PACKAGE_AVAHI=y
> BR2_PACKAGE_AVAHI_DAEMON=y
> BR2_PACKAGE_DBUS=y
>

test-pkg looked good with the above config and the case of avahi&dbus disabled.

Matt
Marcus Folkesson Dec. 26, 2017, 8:16 p.m. UTC | #3
Matthew,

On Tue, Dec 26, 2017 at 02:06:57PM -0600, Matthew Weber wrote:
> Marcus,
> 
> On Mon, Dec 25, 2017 at 10:16 PM, Matthew Weber
> <matthew.weber@rockwellcollins.com> wrote:
> > Marcus,
> >
> > On Thu, Dec 21, 2017 at 5:19 PM, Marcus Folkesson
> > <marcus.folkesson@gmail.com> wrote:
> >> Avahi support also needs libavahi-client, which is built by avahi if avahi-daemon
> >> and dbus is selected.
> >>
> >> Fixes:
> >> http://autobuild.buildroot.net/results/1edfb60add17945eabc557e1dbfb08a0ba466df9/
> >>
> [snip]
> 
> >
> > Tested-by: Matt Weber <matthew.weber@rockwellcollins.com>
> >
> > I've kicked off a validation using utils/test-pkg with the following
> > config and both of your libostree patches applied.
> > BR2_TOOLCHAIN_USES_GLIBC=y
> > BR2_PACKAGE_LIBOSTREE=y
> > BR2_PACKAGE_E2FSPROGS=y
> > BR2_PACKAGE_LIBFUSE=y
> > BR2_PACKAGE_LIBGLIB2=y
> > BR2_PACKAGE_LIBGPGME=y
> > BR2_PACKAGE_XZ=y
> > BR2_PACKAGE_AVAHI=y
> > BR2_PACKAGE_AVAHI_DAEMON=y
> > BR2_PACKAGE_DBUS=y
> >
> 
> test-pkg looked good with the above config and the case of avahi&dbus disabled.
> 
> Matt

Thank you for testing.

Best regards
Marcus Folkesson
Thomas Petazzoni Dec. 28, 2017, 9:56 p.m. UTC | #4
Hello,

On Fri, 22 Dec 2017 00:19:32 +0100, Marcus Folkesson wrote:
> Avahi support also needs libavahi-client, which is built by avahi if avahi-daemon
> and dbus is selected.
> 
> Fixes:
> http://autobuild.buildroot.net/results/1edfb60add17945eabc557e1dbfb08a0ba466df9/
> 
> Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
> ---
>  package/libostree/libostree.mk | 8 ++++++--
>  1 file changed, 6 insertions(+), 2 deletions(-)
> 
> diff --git a/package/libostree/libostree.mk b/package/libostree/libostree.mk
> index 612c284870..f0aeb8d72a 100644
> --- a/package/libostree/libostree.mk
> +++ b/package/libostree/libostree.mk
> @@ -27,9 +27,13 @@ else
>  LIBOSTREE_CONF_OPTS += --without-openssl
>  endif
>  
> -ifeq ($(BR2_PACKAGE_AVAHI),y)
> +# Avahi support needs libavahi-client, which is built by avahi if avahi-daemon
> +# and dbus is selected. Since there is no BR2_PACKAGE_LIBAVAHI_CLIENT config
> +# option yet, use the avahi-daemon and dbus config symbols to check for
> +# libavahi-client.
> +ifeq ($(BR2_PACKAGE_AVAHI_DAEMON)$(BR2_PACKAGE_DBUS),yy)
>  LIBOSTREE_CONF_OPTS += --with-avahi
> -LIBOSTREE_DEPENDENCIES += avahi
> +LIBOSTREE_DEPENDENCIES += avahi dbus

Adding the dependency on dbus here isn't needed: libostree doesn't need
dbus itself, it only needs libavahi-client. So I've applied your patch,
but after dropping the dbus dependency.

Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/libostree/libostree.mk b/package/libostree/libostree.mk
index 612c284870..f0aeb8d72a 100644
--- a/package/libostree/libostree.mk
+++ b/package/libostree/libostree.mk
@@ -27,9 +27,13 @@  else
 LIBOSTREE_CONF_OPTS += --without-openssl
 endif
 
-ifeq ($(BR2_PACKAGE_AVAHI),y)
+# Avahi support needs libavahi-client, which is built by avahi if avahi-daemon
+# and dbus is selected. Since there is no BR2_PACKAGE_LIBAVAHI_CLIENT config
+# option yet, use the avahi-daemon and dbus config symbols to check for
+# libavahi-client.
+ifeq ($(BR2_PACKAGE_AVAHI_DAEMON)$(BR2_PACKAGE_DBUS),yy)
 LIBOSTREE_CONF_OPTS += --with-avahi
-LIBOSTREE_DEPENDENCIES += avahi
+LIBOSTREE_DEPENDENCIES += avahi dbus
 else
 LIBOSTREE_CONF_OPTS += --without-avahi
 endif