diff mbox series

libostree: disable manpages/documentation generation

Message ID 20171202075849.4439-1-marcus.folkesson@gmail.com
State Accepted
Headers show
Series libostree: disable manpages/documentation generation | expand

Commit Message

Marcus Folkesson Dec. 2, 2017, 7:58 a.m. UTC
--enable-man is set to `auto` as default, which may break builds.

Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
---
 package/libostree/libostree.mk | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni Dec. 2, 2017, 1:44 p.m. UTC | #1
Hello,

On Sat,  2 Dec 2017 08:58:49 +0100, Marcus Folkesson wrote:
> --enable-man is set to `auto` as default, which may break builds.
> 
> Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
> ---
>  package/libostree/libostree.mk | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)

Applied to master, thanks. I've added a reference to an autobuilder
failure that should be fixed by this. It would be good if you could add
such references yourself in the future when you submit a patch that
fixes a build failures.

Thanks!

Thomas
Marcus Folkesson Dec. 2, 2017, 1:59 p.m. UTC | #2
Hi,

On Sat, Dec 02, 2017 at 02:44:24PM +0100, Thomas Petazzoni wrote:
> Hello,
> 
> On Sat,  2 Dec 2017 08:58:49 +0100, Marcus Folkesson wrote:
> > --enable-man is set to `auto` as default, which may break builds.
> > 
> > Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
> > ---
> >  package/libostree/libostree.mk | 7 ++++++-
> >  1 file changed, 6 insertions(+), 1 deletion(-)
> 
> Applied to master, thanks. I've added a reference to an autobuilder
> failure that should be fixed by this. It would be good if you could add
> such references yourself in the future when you submit a patch that
> fixes a build failures.

Absolutely, thank you.
I was not sure how long the log exists and the link is valid, so I omitted it from the commit message.

> 
> Thanks!
> 
> Thomas
> -- 
> Thomas Petazzoni, CTO, Free Electrons
> Embedded Linux, Kernel and Android engineering
> http://free-electrons.com

Best regards
Marcus Folkesson
Thomas Petazzoni Dec. 2, 2017, 2:05 p.m. UTC | #3
Hello,

On Sat, 2 Dec 2017 14:59:26 +0100, Marcus Folkesson wrote:

> > Applied to master, thanks. I've added a reference to an autobuilder
> > failure that should be fixed by this. It would be good if you could add
> > such references yourself in the future when you submit a patch that
> > fixes a build failures.  
> 
> Absolutely, thank you.
> I was not sure how long the log exists and the link is valid, so I omitted it from the commit message.

We include autobuilder references in all our commit logs, when the
commit fixes a build failure. The links are permanent and never expire
(with the notable exception of a recent hard disk crash at the end of
October, that made us lose all the build results prior to this date).

Best regards,

Thomas
diff mbox series

Patch

diff --git a/package/libostree/libostree.mk b/package/libostree/libostree.mk
index bac44ddbdb..19a00a25f7 100644
--- a/package/libostree/libostree.mk
+++ b/package/libostree/libostree.mk
@@ -12,7 +12,12 @@  LIBOSTREE_LICENSE = GPL-2.0+
 LIBOSTREE_LICENSE_FILES = COPYING
 LIBOSTREE_DEPENDENCIES = e2fsprogs host-pkgconf libfuse libglib2 libgpgme xz
 
-LIBOSTREE_CONF_OPTS += --with-gpgme-prefix=$(STAGING_DIR)/usr
+LIBOSTREE_CONF_OPTS += \
+	--with-gpgme-prefix=$(STAGING_DIR)/usr \
+	--disable-gtk-doc \
+	--disable-gtk-doc-html \
+	--disable-gtk-doc-pdf \
+	--disable-man
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 LIBOSTREE_CONF_OPTS += --with-openssl